Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 8,824
» Latest member: junny2233
» Forum threads: 1,013
» Forum posts: 4,304

Full Statistics

Online Users
There are currently 63 online users.
» 0 Member(s) | 60 Guest(s)
Bing, Google, Yandex

Latest Threads
Windows 10/11 setup Error...
Forum: Ventoy Discussion Forum
Last Post: nguyen ha thai trong
9 hours ago
» Replies: 26
» Views: 11,994
Cannot access Partition 1...
Forum: Ventoy Plugin Forum
Last Post: Steve2926
10 hours ago
» Replies: 8
» Views: 150
文件注入插件似乎不支持太大的文件
Forum: Ventoy Plugin Forum
Last Post: venster
Today, 09:27 AM
» Replies: 2
» Views: 137
Pathing edit
Forum: Ventoy Discussion Forum
Last Post: Reyes
Yesterday, 10:40 PM
» Replies: 14
» Views: 391
Ventoy Persistence-Modus ...
Forum: Ventoy Plugin Forum
Last Post: Werner
Yesterday, 05:32 PM
» Replies: 10
» Views: 922
Windows 10 legacy mode se...
Forum: Ventoy Discussion Forum
Last Post: Steve2926
Yesterday, 08:38 AM
» Replies: 12
» Views: 335
Problem booting windows i...
Forum: Ventoy Discussion Forum
Last Post: nguyen ha thai trong
09-30-2022, 12:52 PM
» Replies: 0
» Views: 87
Secondary menu
Forum: Ventoy Discussion Forum
Last Post: longpanda
09-30-2022, 01:05 AM
» Replies: 3
» Views: 308
Ventoy commercial version
Forum: Ventoy Discussion Forum
Last Post: aboamir@gmail.com
09-29-2022, 10:55 PM
» Replies: 1
» Views: 130
Ventoy默认启动设置
Forum: Ventoy Discussion Forum
Last Post: longpanda
09-29-2022, 07:34 AM
» Replies: 3
» Views: 556

 
  [SOLVED] persistence difficulty
Posted by: captain-sensible - 05-31-2020, 12:37 PM - Forum: Ventoy Discussion Forum - Replies (21)

i have no problem with formating disk and have several iso's in a 14gig stick all but one booted.

on a new 4gig stick i am trying to get persistence with  linuxmint-19.3-xfce-64bit.iso which i note docs mention has been tested.

First my formated usb stick when mounted. it looks like  this:

ventoy
├── CreatePersistentImg.sh
├── ISO
│   └── linuxmint-19.3-xfce-64bit.iso
├── persistence.img
└── ventoy.json

in ventoy.json I have :

{
  
   "control": [
        { "VTOY_DEFAULT_MENU_MODE": "1" },
        { "VTOY_FILT_DOT_UNDERSCORE_FILE": "1" },
        { "VTOY_DEFAULT_SEARCH_ROOT": "/ISO/" }
    ]
     
    "persistence" : [
        {
            "image": "/ISO/linuxmint-19.3-xfce-64bit.iso",
            "backend": "persistence.img"
        }
    ],
   
 //there was a missing ", "    above but still not working
   
   
   
}



the first thing i note is that when CreatePersistentImg.sh is run i get a file  called  "persistence.img"
i did see in docs such as :

/persistence/ubuntu_20.04_1.img",",

would i be right that  persistence.img is renamed to "ubuntu_20.04_1.img"
and is at /ventoy/persistence/ubuntu_20.04_1.img and ventoy.json is edited accordingly ?

also when running CreatePersistentImg.sh i get an issue:


bash-5.0$ cd /run/media/andrew/ventoy/
bash-5.0$ ls --color
CreatePersistentImg.sh  ISO  ventoy.json
bash-5.0$ su
Password:
bash-5.0# chmod a+x CreatePersistentImg.sh
bash-5.0# ./CreatePersistentImg.sh
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB, 1.0 GiB) copied, 113.815 s, 9.4 MB/s
mke2fs 1.45.5 (07-Jan-2020)
/dev/loop0 contains `ISO-8859 text, with very long lines, with no line terminators' data
Proceed anyway? (y,N)

i just entered y
as i say i acn boot iso but there is no sign of choice of choice of selecting persisitence

Print this item

  用MediaCreationTool2004下载的32位64位二合的ISO不支持
Posted by: fhx123 - 05-30-2020, 11:59 PM - Forum: Ventoy Discussion Forum - Replies (6)

用MediaCreationTool2004从官网下载的32位64位二合的ISO可以启动,但进入安装系统时会提示找不到驱动,安装进行不下去。

Print this item

  Rename Function
Posted by: vishalvodro - 05-30-2020, 06:26 PM - Forum: Ventoy Discussion Forum - No Replies

The 1.0.12 release is a huge improvement without a doubt! Many implementations have been done. Only found one option is missing or required, i.e: Rename function on the go.

Since Ventoy doesn't work on those ISOs with Space in it's name, it's better if we could Rename those files there only while ventoy is on. And next reboot we can get it worked smoothly...

Thank you for your tremendous development.

It's a revaluation in the USB ON THE GO era...

From INDIA with LOVE...

Print this item

  fat32 filesystem type support for the first partition
Posted by: dee - 05-26-2020, 05:10 PM - Forum: Ventoy Discussion Forum - Replies (1)

Since 1.0.10 release a lot file system formats supported by Ventoy.But fat32 is not. It would be great to add support FAT32 sine many older linux distros does not support exFat and windows distros not supporting ext file system. Minor disadvantage is file size less than 4GB per ISO but i can live with it.

Print this item

  switching between tree mode and default mode
Posted by: FOW0RYL - 05-26-2020, 08:26 AM - Forum: Ventoy Discussion Forum - Replies (7)

Hello,
I have added the  Global Plugin code to the existing theme entry in the ventoy.json file.
Ventoy is startin in treemode as described. Works fine so far.
At the bottom line there is a permanent hint "F3: Treemode".
When pressing F3, the system switched to default mode. But the hint doesn't change.
When pressing F3 again nothing happens. When playing around, I found that I have to press alternating ESC and F3, to switch between modes. Confusing.

I would like to have a correct hint Smile

Print this item

  Custom theme fonts
Posted by: PlumberOfSound - 05-26-2020, 02:10 AM - Forum: Ventoy Discussion Forum - Replies (5)

Playing around with Ventoy and themes I found that the theme fonts (or custom fonts I create) are not loaded unless I add the to the EFI partition under grub/fonts and then edit grub.cfg and add them in using loadfonts.  I'm no grub expert so maybe there is a better way to to do this that is more dynamic?  Or is this a feature request to be something that is configurable in the theme object in ventoy.json?

Print this item

  Using ventoy to install opensense[error in mounting CD/DVD-device]
Posted by: Thhunder - 05-25-2020, 09:54 PM - Forum: Ventoy Discussion Forum - No Replies

Hey Guys,
i'll try to use Ventoy to install my firewallsoftware opensense. first it boots correctly, but at one time its looking for an CD/DVD-ROM device to mount, at this point it breaks up because Ventoy maybe does not emulate this correct?
opensense is based on freeBSD and starts at a live-system at the first point there looks it good after the bootscreen of opensense you can chose to boot up as single user or multiuser system or an rescue mode (if i remember correctly) at this point is anything ok.
After it starts to bootup it goes into the live mode and fails at the point when it mounts up the filesystem from the CD/DVD-ROM it fails because there is no hardware CD/DVD to find and no CD/DVD-ROM device.

after all, i love it to use ventoy because i have less time with flashing an iso to USB stick anymore so please work on it more it's the best tool i have ever found on the web!

greets

Thh

Print this item

  auto_install grub entries
Posted by: PlumberOfSound - 05-25-2020, 09:30 PM - Forum: Ventoy Discussion Forum - Replies (10)

New to Ventoy and already a fan.  The part that pulled me to Ventoy over anything else, including hardware based ISO emulators, was the auto_install plugin, essentially raising Ventoy above simple ISO booting to a full fledged kickstart.  A a question on auto_install, however: once I configure a auto_install entry does that create a unique grub entry or does it mean that every time I attempt to boot the ISO configured it always uses the kickstart script?

Print this item

  Grub File Manager to Ventoy Boot
Posted by: awengers44 - 05-23-2020, 05:56 PM - Forum: Ventoy Discussion Forum - Replies (7)

Seamless transition between multiboot systems.
https://m.youtube.com/watch?v=ahBcxLpU2Eg
Shortcut key f6
https://yadi.sk/d/upifZh-ciDq2zw

Print this item

  [FEATURE REQUEST] Resize the existing partition instead of format the drive
Posted by: KaMyKaSii - 05-23-2020, 12:44 AM - Forum: Ventoy Discussion Forum - No Replies

I know you haven't added that support yet because you don't want a headache with users losing their data and blaming you, but I don't see why not adding a parameter to resize and install Ventoy keeping current data. You just need to make it clear that the user is responsible for any data loss. Today I did it manually on my external HD and it worked perfectly, if anyone wants to try it, here are the instructions:

To boot with UEFI:

  1. Install Ventoy on any flash drive and make a dd backup of the second partition EFI that Ventoy created on the flash drive
    Code:
    sudo dd if=/path/to/the/part2/of/ventoy/flash/drive of=part2-EFI.img

  2. Resize the NTFS partition of the external HD using Gparted or any similar tool, leaving 32MB at the end of the disk and then create an ext4 partition in that space (on the first attempt Gparted failed because my NTFS partition had some errors, I had to restart on Windows first and run the command "chkdsk /f /x H:" on my external HD to correct these errors).
  3. Restore the dd backup of the second partition EFI on the second partition that you created before
    Code:
    sudo dd if=part2-EFI.img of=/path/to/the/part2/of/external/hd

To boot with Legacy BIOS:
       
  1. First you need to follow all the steps for UEFI
  2. Backup the first 1MiB of a flash drive created by Ventoy
    Code:
    sudo dd if=/path/to/ventoy/flash/drive of=VentoyMBRandGAP.img bs=1MiB count=1

  3. Backup the original MBR of the external HD as a precaution in case something goes wrong
    Code:
    sudo dd if=/path/to/external/hd of=OriginalMBRandGAP.img bs=1MiB count=1

  4. Backup the original partition table of the external HD
    Code:
    sudo dd if=/path/to/external/hd of=OriginalPartitionTable.img skip=446 bs=1 count=64

  5. First you have to check by GParted that your first partition starts in sector 2048 (1048576 bytes). If yes, you can restore the VentoyMBRandGAP.img to the external HD
    Code:
    sudo dd if=VentoyMBRandGAP.img of=/path/to/external/hd bs=1MiB count=1

  6. Restore his original partition table
    Code:
    sudo dd if=OriginalPartitionTable.img of=/path/to/external/hd seek=446 bs=1 count=64

  7. Use fdisk to change the partition 2 type and set the boot flag (you need to paste all lines at once on terminal and press enter)
    Code:
    echo "t
    2
    ef
    a
    1
    w" | sudo fdisk /path/to/external/hd

Notes:
When I say "/path/to/ventoy/flash/drive" or "/path/to/external/hd" I mean the path of the entire block device such as "/dev/sdb" or "/dev/sdc".
When I say "/path/to/the/part2/of/ventoy/flash/drive" or "/path/to/the/part2/of/external/hd" I mean the path of the specific partition block such as "/dev/sdb2" or "/dev/sdc2"
You can find these values on your system using the lsblk command

Print this item