Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows 10 Installation issues
Hello, I'm fairly new to Ventoy so I might just be doing something wrong... I'm attempting to install Windows 10 on a laptop of mine but I get some weird issues.

I have the flashdrive formatted using Ventoy with MBR partition style.

The laptop's bios being set to UEFI allows the installation to work without issues, But if I attempt to install using BIOS it will allow me to select it in Ventoy's menu, It will finish the "Loading files..." option but as soon as it's done it will provide a black box that appears over the Ventoy menu and will stay there forever, it will then flash the entire screen black ones and go back to the black box over the ventoy menu.

I read some forum posts and was recommended to enable Wimboot mode and this provides a different issue, It proceeds through the installation like normal but upon selecting a Drive to install windows on and pressing "Next" it tells me "We couldn't create a new partition or locate an existing one. For more information, see the Setup log files." and won't let me select the drive.

I was also recommended to enable comparability mode, upon hitting "Install" it tells me "A media driver your computer needs is missing. This could be a DVD, USB, or Hard disk driver. If you have the CD, DVD, or USB flash drive with the driver on it, please insert it now." And hitting "Browse" I can't seem to find any drivers anywhere so this method also fails for me.

Any help would be nice Smile I'm wanting to create a ventoy USB that I can use on virtually any system to install Windows 10, be it UEFI or BIOS, laptop or desktop, Old or new, etc.
1. With normal mode, before you select the ISO file to boot, press F7 to switch to TEXT mode and then select the ISO file to boot.

2. With wimboot mode, try firstly delete all the existing partitions before you press "Next"
With text mode it proceeds to the "Loading files..." Then brings me to the GUI ventoy menu and freezes

I tried removing all partitions as well as creating new ones, and all provided the same error message
Boot using wimboot mode to Setup.
Then press SHIFT+F10 to get command console
Then use DISKPART and type these commands
do you see the USB drive and the hard disk you want to install to listed?

If so try these commands (booting in UEFI64 mode):
SEL DISK N (where N is the number of the disk you want to install to)

Then try to install

If booting in MBR mode you need to use CONVERT MBR
I see my DISK 0 which is my 120GB SSD, and DISK 1 which is my 120GB flashdrive

I did as you said and converted it to GPT, It provided the same "We couldn't create a new partition or locate an existing one. For more information, see the setup log files." I also went through and converted it to MBR and tried again, and again to GPT and all provided the same issue even after refreshing after each change. I did go back to list disk and it shows the * populated under GPT, so its correctly converting it.
Try using DISKPART to format the SSD. It sounds like it has a problem.
Been dealing with this same problem for few days. The installer say: "We couldn't create a new partition or locate an existing one. For more information, see the Setup log files."
I've tried all the internet suggested with no avail. I thought it was the ventoy, so i try another program to burn the iso to USB. Apparently it produce the same error. So i concluded the problem is the disk or the windows installer that interact with it, not the ventoy.
Then i plugged out all other HD except the one that i want to install the windows. And voila, it went through without the problem.
Windows will want to install boot files on the boot disk in the system
The boot disk may not be the same disk that you are installing to.
You may have UEFI booted for instance but the boot disk is in MBR partition mode.
I'm having the same error.  

Using Ventoy 1.0.91, MBR partition on a SanDisk Ultra USB 3.0 128gb
ALWAYS use Microsoft's MediaCreationTool to download Windows 10 ISOs directly, no other source
Example system is ThinkPad W510, fully updated BIOS, non UEFI system with Secure Boot disabled
Set USB HD to boot first
Installed brand new Samsung EVO 970 2.5" 500gb SSD SATA interface.
There are NO OTHER DEVICES connected to the laptop except the thumb drive with Ventoy and the blank internal SSD.  
No ethernet.  There is an internal DVD drive, but it is not an option for install and so never appears as a choice to install to.

Boot Ventoy.  Select Win10 22H2 ISO just downloaded 6-12-23
Normal mode brings black screen with flashing white cursor upper left corner.  Have left for 30 minutes multiple times.  Never proceeds.
wimboot mode boots ISO
Windows Setup, English, US, Next
Install Now
Activate Windows screen - click I don't have a product key - computer already registered for a license with MS
Win10 Pro x64 dated 5-5-23, next
Accept license terms, next
Custom (upgrade does nothing as drive is blank)
click on Drive 0 Unallocated Space, next
"We couldn't create a new partition or locate an existing one. For more information, see the Setup log files"

Troubleshooting notes:
Used Rufus to take same ISO and create a dedicated USB Thumb drive (DataTraveler 100G3 16gb), boot, after clicking on Drive 0 unallocated Space and hitting next,
           it creates a partition and starts copying files for the install.
           Power off the computer during the copy, leaving the partition.  
So given the success with the Rufus created thumb, seems likely the ISO is fine.
Remove Rufus, insert Ventoy.  STILL FAILS with the error when selecting the Rufus created partition.  

For troubleshooting, I tried selecting Home, Education and Pro, both x86 and x64.  ALL do the same, get the error
I tried creating a partition manually and formatting it from the screen where you select where to install, still get the error
    In the past I have not needed to do this step, just click on the Unallocated Space, and hit next and it takes off.
I tried changing Ventoy to GPT instead of MBR, which should not matter on a 500gb drive.  Still get the error
I tried checking Secure Boot Support from Ventoy2Disk, just for giggles, Still get the error
I tried running Ventoy2Disk and cleaning the thumb, then installing again.  Still get the error
Used SanDisk Extreme Pro 512gb SSD USB thumb drive, installed Ventoy 1.0.91.  Still get the error

To be able to boot a Rufus created thumb on non-UEFI systems, I must select MBR partition scheme to get it to boot the install
but once booted the install proceeds without issue.  
I've tested other ThinkPads of similar age, non-UEFI systems.  ALL do the same thing.  
I've also tried YUMI.  I get the same error.  It has components of Ventoy in it, so no surprise.  

I've googled this error.  
I've tried using the diskpart procedure.  Did not work for me.  

SOMEONE please help me out.  
I'll try anything at least once.  LOL.
Please give me the link to download your windows 10.iso

Forum Jump:

Users browsing this thread: 2 Guest(s)