Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux vdi.vtoy giving 'Not official Ventoy' Warning
I prepared a Linux Mint vdi using Virtual Box v5
I first booted in Legacy mode to the virtual ISO in the VM which made a FAT partition and an ext4 partition on the vdi and installed Legacy Mint. [This was done because if preparing a GPT/UEFI64 Mint install I did not know how to make it Legacy bootable as I could not create a legacy boot partition using gparted.]

I then added in grub EFI files using

sudo  apt-get  install  grub-efi-amd64-bin
sudo  grub-install  --force  --removable  --target=x86_64-efi --efi-directory=/boot/efi  --bootloader-id=Ubuntu
sudo  update-grub

This worked fine and I could then Legacy and UEFI boot under VBox.
Next I ran the script which gave one fail message but seemed to succeed - see attached screenshot.
I added the Ubuntu_Mint.vdi.vtoy file to my USB drive.
I can successfully boot the file from a Ventoy USB drive.
I can successfully Legacy-boot from a non-Ventoy grub4dos and grub2 USB drive.
However, if I try to UEFI64 boot from a non-Ventoy grub4dos-for-efi (grub4efi) or grub UEFI64, I get a WARNING message about not being an official Ventoy drive and a delay of 10 seconds - however after the 10 seconds, on most systems it does actually boot to Mint Desktop OK.
Is this Warning message expected?

Attached Files Thumbnail(s)

Forum Jump:

Users browsing this thread: 1 Guest(s)