Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with EasyOS
I tested EasyOS 3.4.1 with Ventoy and it was OK, no problem.
Today I've tested EasyOS 3.4.7, but it does not boot and give an error and a Kernel Panic.

erro: file '/lib/modules/5.15.35/kernel/drivers/dax/dax.ko' not found.
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I tested on two different systems, on ACER EeePC 1015CX, 320 GB HDD and 2 GB ram and on
HP Z220 Workstation 128 GB SSD and 1 TB HDD, 16 GB ram.
To test I used Verbatim Store'n'Go 8 GB and Kingston DataTraveler 100 G3 32GB.

I also verify that the problem appears with version 3.4.3 and is present in version 3.4.4, 3.4.5, 3.4.6, 3.4.7 of EasyOS.

I use Ventoy version 1.0.74.

Writing EasyOS-3.4.7-amd64.img on the same key using Win32DiskImager-1.0.0-binary run OK.
This CI release should have fixed it.
(05-02-2022, 11:02 AM)longpanda Wrote: This CI release should have fixed it.
I've used CI #776 to get past the dax obstacle on Easy /dax/dax.ko not found which was successful in getting to the EasyOS boot menu and process, but does not boot EasyOS 3.4.5 or 3.4.7 to the desktop.

I'm not a developer/coder; I'm just a previously Windows now longtime linux user of intermediate expertise.  My experience w/ Ventoy from linux Web has been very good/ excellent/ for dozens of linux distro/s; previously I used Win Yumi for multibooting. The purpose of this report is to rebut some information present at several pages at Ventoy which say Easy OS works w/ Ventoy.

Easy OS,
28 EasyOS

I'm not rebutting the last example in terms of that old v. of Easy, because the current v. of EasyOS is 3.4.7 and my testing has been w/ current Ventoys 1.0.51-1.074  + the Ventoy CI #776 which is 05080402. 

There are currently 2 Ventoy-related topics at the EasyOS forum, one started by someone about the /dax/dax.ko issue which I consider solved by the Ventoy CI #776, and one started by me about the /real/ problem for EasyOS and Ventoy.

Basically, the problem is that Easy's modus operandi at boot time causes it to need to write an .sfs

Quote:One-time only operation, creating a snapshot of EasyOS
This will allow future follback with the Easy Version Control Manager
Populating: /mnt/ventoy2/easyos/releases/easy-3.4.7
initrd vmlinux easy.sfs cp: write error: No space left on device
This copy failed:
cp /mnt/ventoy1/easy.sfs /mnt/ventoy2/easyos/sfs/easyos/oe/dunfell/easy_3.4.7_amd64.sfs
It is possible that the drive is failing.
Attempting to copy again...
cp: write error: No space left on device

That attempted boot was Ventoy upped to CI #776 or 05080402 which solves the failure at the dax step.
(05-18-2022, 05:26 PM)measter Wrote: There are currently 2 Ventoy-related topics at the EasyOS forum, one started by someone about the /dax/dax.ko issue which I consider solved by the Ventoy CI #776, and one started by me about the /real/ problem for EasyOS and Ventoy.

BarryK, the dev of Easy OS provided a couple of different approaches to tweaking the Easy OS .img to help it work w/ Ventoy.

I performed one of those, which I described in the above thread which was successful in Easy booting to the desktop.

Currently the ingredients for successful boot of Easy in Ventoy stick are: up the Ventoy to the CI #776, tweak the Easy .img as BarryK describes
It's different between writing the Easy.img to the USB to boot and boot Easy.img from Ventoy USB.

When you write Easy.img to an USB stick (e.g. 16GB) by Rufus/Etcher and boot it.
Easy OS knows that it's booted from an normal device for example /dev/sdb which is just the USB stick.
Then the /dev/sdb device is avaliable to Easy OS and Easy OS can use all the space(16GB ) of /dev/sdb in theory.
So at the first boot time, Easy OS will try to expand its partition to occupy more space for use.
It's OK because it can use all the 16GB USB space in theory.

When you boot Easy.img from Ventoy it's different.
Ventoy will create a device-mapper (e.g. /dev/dm-0) according to the physical location of  the IMG file.
So Easy OS only knows that it is booted from a device for example /dev/dm-0 which is actually the Easy.IMG file itself, and it can only use the space in the device.
Alough Easy OS can see the /dev/sdb device, but it can not use it because it't not the root device. (Let's imagine that what will happen if it uses /dev/sdb? Of cause it will destroy other ISO/IMG files in the Ventoy USB.)

By default there is very little free space inside the Easy.IMG so there is no more free space for Easy OS to use to expand its partition at the first boot time.
So you will get the NO SPACE error.

It's easy to solve the problem, just expand the size of Easy.IMG and copy the new IMG file to Ventoy and boot it.
You can just append some data to the end of Easy.IMG file as follows:
dd if=/dev/zero bs=1M count=4096 >> Easy.img

Hope the author of Easy OS can preserve enough free space inside the IMG file  for minimum usage scenario when building it.
Some other IMG file did this.

Forum Jump:

Users browsing this thread: 1 Guest(s)