Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Best way to make a new VHD from a Windows 10 ISO
I have a hunch that Steve2926 has hit the target in his post above where he points that BCD might be the culprit here.

E.g., here's the internal disk layout of my Windows 10 VHD, automagically created with VirtualBox under Linux, which boots fine placed on a MBR disk.

[Image: winvhd.png]

That "System Reserved" partition is in fact the EFI boot store and it becomes active only after Ventoy successfully boots the VHD -- prior to that the main boot store is Ventoy's own "VTOYEFI" partition present in the physical boot drive (also hidden).

I have gone the VHDX path before, since my go to recipe for installing Windows 7 in a virtual disk apparently didn't work any longer with 10 -- and, at first, everybody just said it couldn't even be done.

Bear in mind that, should you decide to try it, you'll be restricted to VHDX under mandatory GPT formatted drives and the new UEFI booting scheme

This absolutely won't work with MBR style drives. I have had nothing but endless grief trying to juggle those restrictions under Windows.
Midas, thank you for your ideas on this topic. And then thanks to Steve2926 of his idea of using a VHDX instead of a VHD. I gave that format a try today. But I still have no luck. The same error as described in the first post in step 4 shows up.

So no matter if I use a VHD or a VHDX-file the partitions look like "Disk 0" on this screenshot, that I found on the Internet:[Image: efi-system-partition.png]

I noticed that in the VHD-image created by Rufus basically
  • the partition "System Reserved 50 MB NTFS Primary Partition" at the beginning is missing, instead I have a 260 MB (in this screenshot 100 MB) EFI System Partition" there
  • the "505 MB Recovery Partition" at the end is missing.
That is interesting, although I don't know if that matters here. I would guess that it does matter, because the VirtualBox-approach does create a different layout that is working, as Midas has shown. By the way, the partition layout is the same at creation time and after the first boot. So Windows 10 does not create any additional partitions during its first boot process - at least not until the previously mentioned error shows up.

Interestingly, the Rufus-page mentions that Windows ISO is compatible with Ventoy:
Quote:[...] or you might as well use Ventoy (which is most likely what you are looking for) or RMPrepUSB or Easy2Boot or YUMI as there already exist quite a few solutions to perform what you seek.

So I thought about another method, described at

Using Ventoy I booted from the Windows ISO, pressed SHIFT + F10 at the setup screen and created a VHD with DISKPART-commands there on the fly. However, at some point of the installation process it shows me the exact same error as mentioned in the first post shown in step 4. I repeated the same approach using a VHDX, just to make sure. So even two approaches, one with Rufus, one using the DISKPART-commands of Windows cannot produce a new, bootable VHD or VHDX. I try to investigate further, any ideas are of course welcome.

Forum Jump:

Users browsing this thread: 1 Guest(s)