Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
External harddisk is not recognized/not available in the boot menu
I use an Asus M5A97 R2.0 board with a UEFI bios. Windows 10 (installed in BIOS mode) and Manjaro 20.1.2 (installed in UEFI mode) are used as operating system. Both are installed on different SSD. No boot manager like Grub2 is used, I have to use the boot menu of the computer (F8 key after booting the computer) to select the desired operating system. That is also intended. Each hard disk is listed twice: 1x under her normal name and 1x with the prefix "UEFI".

Furthermore, I still own 3 external storage media:  an external 3.5" HDD, a docking station and a 2.5" HDD. 

Now I have two problems:

Problem one:  When I start Ventoy under Windows, I only see the 3.5" HDD and the disk in the docking station. If I install Ventoy on it, I can also boot the computer from it and everything works perfectly. But I have to select the UEFI entry for the hard disk in the boot menu, they don't start with the normal entry.
However, I would also like to install Ventoy on the 2.5" HDD. But this does not work, because the hard disk is found by Windows, but not by Ventoy.  Why is that and how can I install Ventoy on it?

Problem 2: I have installed Ventoy on Manjaro as a test and thus installed Ventoy on the 2.5" HDD. As installation command I have entered this:  "./Ventoy -i -g /dev/sdd" 
The "-g" is necessary because the 2.5" HDD is larger than 2TB and therefore MBR will not work. 
The result: When I now try to boot from this hard disk, I only get the text "GR" in the upper left corner. This is probably due to the fact that I have no choice of UEFI mode for the 2.5" HDD, i.e. the entry is simply missing. How can I install Ventoy so that the computer also recognises this disk in UEFI mode?
1. To prevent misoperation, Ventoy2Disk.exe only lists USB drives by default.
You can run Ventoy2Disk.exe -U from CMD then all the disks will be listed. But at this time, you must be very careful and don’t choose the wrong disk.

2. I think you can disable some BIOS option about CSM to make your machine only support UEFI mode and test again.

Forum Jump:

Users browsing this thread: 1 Guest(s)