Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Arch Linux ISO boots via BIOS, fails to boot via EFI
#1
On an Intel NUC, I can use Ventoy in BIOS mode to boot the Arch Linux installation ISO.

If, on the same Intel NUC, I use Ventoy and EFI mode, the boot will fail.

The failure messages is:

Waiting 30 seconds for device /dev/disk/by-label/ARCH_202010 ...
ERROR: '/dev/disk/by-label/ARCH_202010' device did not show up after 30 seconds.

I then get an emergency shell, and I can see the following devices in /dev/disk/by-label:  Recovery and VTOYEFI

Recovery is probably Windows 10 on another disk.

If, instead, I boot via BIOS, the following disks exist in /dev/disk/by-label:
ARCH_202010, Recovery, and VTOYEFI.  ARCH_202010 is a symlink to /dev/dm-0.

Attached are screenshots of (1) the EFI error message, and (2) ls -l /dev/disk/by-label after a successful BIOS boot.


Attached Files Thumbnail(s)
       
Reply
#2
I don't know if it would make a difference, but the partition that holds all my ISO files is formatted with ext4.
Reply
#3
In the shell, please run cat /ventoy/log
Reply
#4
Nice sait.
Special thanks to the project manager Alex_Mimo_Liza for the responsible and professional solution of the tasks.
https://damainmyememeii.com
Reply
#5
It's a bug and has been fixed and will be ok in the next release.
https://github.com/ventoy/Ventoy/issues/516
Reply
#6
Please try Ventoy-1.0.23
Reply
#7
The report button is gone, but the post above by Wlatergluro is SPAM (and 404).

https://forums.ventoy.net/showthread.php...75#pid2375
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)