Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Ventoy BOOT Problem - GRUB Error
Greetings!  GRUB newbie here.  I've been using VENTOY successfully on lots of machines, mostly Legacy-MBR types.  I just tried to use it on an HP 8510p Core2Duo (Legacy-MBR) and GRUB flashes an error (too fast to see) and winds up at the GRUB prompt.

I used the "ls (hd0,1)" and "ls (hd0,2)" GRUB commands to give a quick look at the partitions on the VENTOY build (which is a 1tB USB HDD).  Partition 1 looks normal seeing an exFAT FileSystem with the proper label and size.  Partition 2 says "No known FileSystem detected" with the proper 32mB size.  All my partition tools say that the 32mB partition is of the FAT16 type.

Any idea what might be happening here...???  Thanks in advance for any offered help.
After some follow-up work, it seems to be a VENTOY vs BiOS issue of some sort with GRUB being the item that seems to notice the anomaly.  I built a 64gB UFD (USB Flash Disk), a 128gB SSD (old one), a 320gB HDD, a 500gB HDD and a 1tB HDD... those were the only options I had to play with when testing this.  All of these options worked in a 2011 vintage LENOVO laptop and anything newer I could get may hands on.

The HP8510p laptop mentioned above is of a 2008 vintage with a final BiOS installed of 2011 vintage.  VENTOY fails to BOOT (with the unseen GRUB error mentioned above) on any of the mentioned USB storage devices larger than 128gB with the HP8510p.  I would love to know if I'm stuck with this limitation or whether the GRUB in use by VENTOY can be "modified" to handle the issue.  As always, thanks for any input the Forum may have.
Please refer
(10-05-2020, 09:57 AM)longpanda Wrote: Please refer
Thanks, LP... sorry I missed that FAQ entry.
Rebuilt the 1tB VENTOY HDD according to LongPanda's FAQ (VENTOY & ISOs below 138gB, NTFS for rest of disk storage purposes) and all works well with older BiOS.  Thanks again for all the help!

Forum Jump:

Users browsing this thread: 1 Guest(s)