Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Ventoy update/upgrade
Hi @all.

There are scant reports of anyone updating -- specifically from v1.0.21 to v1.0.22 -- with Ventoy installed to computer internal HDD/SSD.

I just tried to upgrade my setup (see and by booting a Linux Mint 20 livecd ISO image and issuing the following command in a terminal:

$ sudo sh -u /dev/sda

And got the following error:

/dev/sda does not contain ventoy or data corupted

Please use -i option if you want to install ventoy to /dev/sda

The system is working with no errors with v 1.0.21 -- except for what I reported in the "This is not a standard device and is not officially supported" thread ( -- and I can see all disk perfectly (plus they show up OK in Mint when I run '$ sudo fdisk -l').

[Image: sda1.png]

There was one positive upgrade report ( but I was still afraid it wouldn't work in my case, after other previous reports regarding different Ventoy versions, and so it is... Do I have to reinstall everything? Confused


I just tried Ventoy v1.0.22 for Windows -- because the Linux version apparently doesn't have the '-U' parameter -- and got only the "Install" button active, so "Update" is not an option...

[Image: ventoy-update.png]

As an alternative, is there any chance to perform the update manually? How? Huh
I taught in this topic how to replicate the installation of Ventoy on one device to another, without the need to do the initial standard installation of Ventoy on the desired device and consequently having to format it. Note that I only made it on both disks with MBR partition table and I can only guarantee that it will work (without losing data) if you follow all the steps to the letter. Good luck
(10-02-2020, 11:19 PM)KaMyKaSii Wrote:

Thank you for the tip, KaMyKaSii. Smile

I'm away from the PC until Monday, but I'll check it out then...
Well, I seem to have solved this problem, inspired by KaMyKaSii instructions. Cool

Here's what I did:

  1. I created an updated Ventoy liveUSB and put a Linux (Mint) ISO on it;
  2. I booted the afected PC with this USB;
  3. I ran GParted and deleted the SDD's Ventoy partition ('/dev/sda2' above, but only after copying it to the unallocated free space via right click copy & paste, just in case something went wrong);
  4. I copied the liveUSB Ventoy partition ('/dev/sdc2' in my case) to the space freed in 3.
  5. I set the boot and esp flags on the newly created '/dev/sda2' via GParted context menu.
After rebooting, everything seems to be working as expected with Ventoy displaying "[Unofficial Ventoy] | 1.0.22 UEFI" in the lower left corner of the menu.

So no more delays or awkward warning messages* -- the only quirk being that UEFI part; although this computer is UEFI enabled, I'm running everything in legacy MBR mode... I think. Undecided

*) For details on this, see
Idea When a post helps you in any way, please rate it. Thank you. [Image: rateit.png]

Forum Jump:

Users browsing this thread: 2 Guest(s)