Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
【Solved】Install Ventoy to NVMe under Linux
#1
Star 
Howdy!

I can't get ./Ventoy2Disk.sh to install to an NVMe drive under various Linux distributions, though SATA SSD works fine. I suspect it has something to do with the partition names starting with a p, such as p1, p2, etc. where on SATA it only has the number itself, such as /dev/sdb1, sdb2, etc. With NVMe it looks like /dev/nvme1n1p1, nvme1n1p2, etc. Here is the error where it dumps out:


ubuntu@vps:~/ventoy-1.0.21$ sudo ./Ventoy2Disk.sh -I -r 400000 -s -g /dev/nvme1n1 


**********************************************
      Ventoy: 1.0.21
      longpanda admin@ventoy.net
      https://www.ventoy.net
**********************************************

Disk : /dev/nvme1n1
Model: WDC CL SN720 SDAQNTW-512G-2000 (nvme)
Size : 476 GB
Style: GPT

You will reserve 400000 MB disk space

Attention:
You will install Ventoy to /dev/nvme1n1.
All the data on the disk /dev/nvme1n1 will be lost!!!

Continue? (y/n) y

All the data on the disk /dev/nvme1n1 will be lost!!!
Double-check. Continue? (y/n) y

Create partitions on /dev/nvme1n1 by parted in GPT style ...
Done
mkfs on disk partitions ...
create efi fat fs /dev/nvme1n1p2 ...
mkfs.fat 4.1 (2017-01-24)
success
mkexfatfs 1.3.0
ERROR: failed to open '/dev/nvme1n11' in read-write mode: No such file or directory.
writing data to disk ...
sync data ...
esp partition processing ...

Install Ventoy to /dev/nvme1n1 successfully finished.

ubuntu@vps:~/ventoy-1.0.21$

I tried booting off the livecd.iso, but it only shows /dev/sda and /dev/sdb (which don't exist) and thus it can't install to them, it says "Failed to access /dev/sdb, maybe root privilege is needed". It doesn't show /dev/nvme0n1 and /dev/nvme1n1 if I hit refresh.
Reply
#2
Yes, Nvme is not supported now.
Both the install script and the work script need to be modified.
Reply
#3
Is there a way to create and format the two partitions manually? Or a way I can modify the scripts to attempt to install this tonight? Any tips? ;-)
Reply
#4
I just update  https://github.com/ventoy/Ventoy/blob/ma...yWorker.sh  But I don't have a nvme drive so it's not tested yet.
You can update this script (override the script in the install package) and retry.
Reply
#5
Thanks! I'll give it a try. I was able to get Windows Server 2019 core edition installed and that was enough to run the Windows version to do what I was attempting before heading to bed... hehe! The Windows version worked fine on NVMe (using -U of course).
Reply
#6
Please try with latest release if possiable
Reply
#7
(11-16-2020, 10:57 AM)longpanda Wrote: Please try with latest release if possiable
Wow! Quickfix ... how about support for .sblive images? Thanks again for an amazing tool!

https://forums.ventoy.net/showthread.php?tid=1423
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)