Thread Rating:
  • 2 Vote(s) - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Boot from VHD
#31
(01-12-2023, 10:28 AM)Tokener Wrote:
Quote:nguyen ha thai trong:
your win10.vhd when booting directly via QEMU,Virtual Box is successful, because this is the deciding condition for ventoy boot it ok

thanks for asking,
and YES, specified VHD is booting in VirtualBox OK.
Have you tried specifying the VHD with grubfm.iso and with success?
Reply
#32
(01-10-2023, 03:12 PM)Pupkin_999 Wrote: People, am I the only one who can't boot Windows10.vhd on ventoy-1.0.87, or does everyone else too? So far I've rolled back to ventoy-1.0.84 and everything works.

PS: Kali.vhd, Manjaro.vhd and I suspect any other linux.vhd except Windows works on ventoy-1.0.87

Yeah, I'm having the same trouble with Ventoy 1.0.87 booting my Win11.vhdx when a previous 1.0.8x build worked fine (not sure if it was 1.0.84 or not). I'm getting "0xc000000e There is an invalid object in the Boot Configuration Data store" for an error.

Booting the vhdx via Grub2FM works as a temporary workaround until I find a solution. I'm testing earlier builds of Ventoy to figure out where it broke.

UPDATE: I downgraded to Ventoy 1.0.86 and it boots my Win11.vhdx just fine. There's definitely a bug with 1.0.87 regarding vhdx files.
Reply
#33
This is a bug in 1.0.87 and has been fixed, you can test this CI release:
https://github.com/ventoy/Ventoy/actions...3879364570
https://www.ventoy.net/en/doc_github_ci.html
Reply
#34
Hello nguyen ha thai trong

Thank you very much for your support.

The mistake I have overseen was:
Ventoy payload drive was formatted in ExFAT (formerly default) and not changed by me.
From NTFS partition 22H2-VHD is booting OK.

Regards   T.
Reply
#35
Rejoiced too soon!

VHDboot was successful with 22H2-Windows-VHD if Ventoy was installed on virtual disk, which then was used as HDD-0 in a VirtualBox machine.

When identical situation was on USB3 device (SSD-120GB) and booted by [Virtual Machine USB Boot.x64.exe]
boot process hangs after showing desktop.
Then BSOD (after 2min):
Stop Code: "VHD BOOT INITIALIZATION FAILED"

Same error when booting same USB3 device in real PC.

USB3 device was checked by HDTUNE: no errors.
I will try to make tests on other USB-device and report back.

Best regards  T.
Reply
#36
(01-08-2023, 09:41 AM)Tokener Wrote: Dear Sirs

Thank you very much for sharing Ventoy Tool

I tried booting Windows10 22H2 VHD by using ventoy_vhdboot.img



Windows is starting up to this point:

[Image: vhdbooterror2301089df42.jpg]
Stop Code: VHD BOOT INITIALIZATION FAILED

I guess ventoy_vhdboot.img needs some update.



On the WEB site there is a statement that says:



... so I provide different versions ventoy_vhdboot.img for you to test.

... Easy to update ventoy_vhdboot.img separately

... Easy to customize ventoy_vhdboot.img



My questions are:



- where are the "different versions of ventoy_vhdboot.img" located?

- how do I customize ventoy_vhdboot.img?



Best regards  T.
If you use FIXED size VHD, it should work.
You may create a fixed size one in vbox and use clonezillar or ghost to migrate it.

More details here
* For 1607, both dynmaic and fixed size vhd work.
* But for 22H2, only fixed size VHD works.
Reply
#37
Why do you want to create customize ventoy_vhdboot.img?Use 7 zip to extract the ventoy_vhdboot.img file, you already know the file content like that. Moreover, when creating ventoy_vhdboot.img, the file content must be consistent with the ventoy that longpanda request. I don't see anything to change, if yes create ventoy_vhdboot.img for windows11.vhd if necessary
Reply


Forum Jump:


Users browsing this thread: FroggieTheGremlin, 1 Guest(s)