Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Parted Magic secure erase
I think there is a problem when running parted magics secure erase feature for ATA drives when booting PM from a ventoy usb.

Parted Magic will boot just fine, it will allow you to secure erase NVMe drives, Sanitize ATA Devices, but when you click on Secure Erase ATA drives nothing happens and the menu to select which drive does not appear.

So to test PM I made a PM usb using rufus, ATA secure erase works fine.

Then made a E2B with alives grub2 file manger booted PM with default iso extension and secure erase worked fine, rebooted with alives grub2 file manger and selected the ventoy boot option and secure erase on ATA drives would not work.

So I rebooted the ventoy usb and selected the grubfm_multiarch.iso, selected PM with partnew option and all worked good.

It is only the secure erase of ATA drives that does not work, I can see the drives and their contents with PM file manager.

Tested with

Ventoy 1.14, 1.13

3 systems using uefi and bios

2 different USB drives



Any ideal why this is happening or what could be blocking ATA erase to run or load
I have fixed this issue, and it will be OK in the next release.
Thats great news.

Out of interest what was the problem.

Assume that you USB is  /dev/sdb. When you boot into PM, you will see that  /dev/sdb2 was replaced and it's actually /dev/dm-0
You can delete /dev/sdb2  and recreate it by mknode and then it will be OK.
For example:
mknode -m 0660 /dev/sdb b 8 18

In next release, I will change the mechanism for PM, so it will be OK.
Thanks for the explation and can report 1.15 works great.

Forum Jump:

Users browsing this thread: 1 Guest(s)