Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 Error message during boot
Error message
error: invalid magic number
error: you need to load kernel first
The booting was done via the vlnk feature. At first the booting was successful, but then this error appeared
The English language may be bad Please try to understand me as much as possible  Confused Heart
Here's what happened to the public interest after trial and error
I suspected that the problem was due to a damaged or missing target file, or a failure to format the Ventoy disk. I tried quickly formatting the disk, and I also tried installing another copy of the operating system to diagnose the problem before formatting. Then this solution failed. I formatted the disk in the long way, not the short way, and that worked, I think. Diagnosing the problem lies in moving a text folder that was found after running the feature and then returned it to the section next to the tool, even though the disk was working. I reached the Ventui screen and booted from it beforehand. I will confirm the solution as soon as I finish, as I perform operations on more than one computer.
The English language may be bad Please try to understand me as much as possible  Confused Heart
I'll add here other errors I have seen:

If you end in GRUB prompt, this happens on old computers with BIOS, not UEFI. There's a limitation of 136 GB for the boot volume.
This is documented on ventoy guide and there's an option to leave space unused on the USB device, so the ventoy partition is smaller.

If you get a blue screen with “Invalid Signature Detected”, this is due to Secure boot.
There's an option to load a key from disk. Select the one on the VTOYEFI partition.
Also, try to load default keys on Secure Boot settings, then add the one on the USB device.

If you get this:
Could not create MokListRT: Volume full
Could not create MokListXRT: Volume full
Could not create SbatlevelRT: Volume full
Could not create MokListTrustedRT: Volume full
Something has gone seriously wrong: import_mok_state() failed : volume full

It is related to the TPM. It started happening to me after a few months and I found that disabling the TPM on UEFI lets me boot from USB again
Tried to reset the UEFI to defaults, clear the TPM contents.... nothing
Finally used CLEAR CMOS jumper on the motherboard and now I can boot with TPM and Secure boot enabled.

Forum Jump:

Users browsing this thread: 1 Guest(s)