Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux vDisk Boot Plugin + vdiskchain
First of all, thanks for releasing this brilliant software/utility - seriously, its exactly what many of us needed.
Now for the problem:

So i have Elementary OS 6.1 installed on a VHD using the latest VirtualBox 6.1
The VHD is 16Gb with a 280 MB EFI and balance Ext4
Ran vtoy shell script and it ran successfully.

OS boots fine and after changing the filename of vhd to *.vhd.vtoy i can copy it to any ventoy usb and boot.

Created vlnk.vtoy to the above vhd saved on my harddisk /SSD (using latest ventioy 1.0.80) and copying that file to any ventoy usb boots the linux vhd from my hard disk.

Added: chainloader (hd0,1)/EFI/vdiskchain vdisk=/VMs/eOS62/eOS62.vhd.vtoy

to grub.cfg using grub-customizer and also by directly typing it on a grub shell or pressing 'e' to edit grub menu during boot.

Now when it boots i get a blank screen. Both vdiskchain & vhd are found and loaded
And on checking the console I can see its not going ahead on:  "loading initial ramdisk ..."

So i ran again. 
Somehow, the grub.cfg on the EFI partition of this VHD shows me different things while the script makes changes in some different grub.cfg

If i run grub-customizer and make some changes then i can see them in grub.cfg but on booting the grub menu that comes up is different (its the one that is editing/creating)

So i have tried a few times to mount the EFI partition and try to see from where the grub.cfg is coming but nothing yet.

Any idea what i should check ?

Forum Jump:

Users browsing this thread: 1 Guest(s)