Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ventoy + MSI B550 A-Pro = Corrupts UEFI Language
Ventoy (today's release) has an interesting bug here ...  Confused

My motherboard is an MSI B550 A-Pro with the latest Beta BIOS (AGESA After upgrading my Ventoy USB stick and enabling Secure Boot, I rebooted my machine to enable Secure Boot in my BIOS and attempt to enroll the key. Upon entering the BIOS, the language settings becoming a hodgepodge of Chinese, Spanish, and English that navigation for me was impossible!  Cry

Once the Ventoy USB is removed and the PC is rebooted back into BIOS, the issue is gone - everything is in English. 
However, if the Ventoy USB stick is re-inserted and I enter BIOS after another reboot, the corrupted language issue resurfaces. 

I'm positive that this issue can be recreated across all MSI B550 and X570 motherboards and isn't unique to my B550 A-Pro ...  Dodgy

Furthermore, as long as my Boot Device Order was set to UEFI USB stick first followed by Windows Manager (i.e my M.2 drive), if I let my motherboard attempt to boot the Ventoy stick since it's first in the boot order, a blue OK box appears in the lower right corner. If I press ENTER, two "unable to boot file" errors appear in white text near the center of my screen and a 10 second boot countdown occurs, after which my M.2 drive is booted and I'm back into Windows. Since this is a continuous loop, the issue prevented me from enrolling the key. But I stumbled on a solution by accident. I set my Boot Device Order in my BIOS to M.2. drive first and UEFI USB stick last, and saved my BIOS settings. Once my system restarted, I pressed F11 to bring up the Boot Override BBS and manually chose the Ventoy stick. I was then able to follow the prompts to enroll the Secure Boot key and upon reboot, Ventoy launched without issue and even booted to a Linux Mint LIVE CD!  Big Grin
Do you have the same problem with previous Ventoy ? (1.0.75/1.0.74....)
Nope, but I also didn't have Secure Boot enabled in my BIOS nor on the Ventoy stick. I doubt that would matter much as I'm sure something else is triggering the language corruption. Never seen it happen on previous versions of Ventoy. When I first bought the B550 A-Pro last October, I also started using Ventoy because YUMI was becoming unreliable. At that time, Ventoy's Secure Boot wasn't compatible with this board and there was no way I could get it to boot to the MOK Manager to enroll the key. Since then, Ventoy development improved and MSI released three more BIOS updates so I don't I could give you an exact point where the incompatibility issue was resolved to the point where enrolling the key was possible or even if Ventoy's the culprit here.

I have a spare USB stick to experiment with. I'll try previous versions of Ventoy to see if I can track down where this language corruption issue first cropped up and get back with you.

UPDATE: The problem appears as far back as ...  Cry  I've installed two BIOS updates since then ...  Dodgy  I was on the December BIOS (7C56vA8) when I first tried to enroll the Secure Boot key to no avail. No language corruption back then. I was on the March BIOS (7C56vA9) when I bought two 32GB USB 3.1 Lexar jump drives -- 1 for YUMI, 1 for Ventoy -- and didn't have the language corruption there, either. Those flash drives passed all my tests. Also, my YUMI stick and my Windows 11 Install USB (created with Rufus) doesn't cause language corruption. This is limited to Ventoy and the two most recent BIOS updates from MSI ... 
very good。thanks。。。
Does this problem occur on both Ventoy GPT USB drives AND Ventoy MBR USB drives?
Yes, it does. When it happened to me the first time, my Ventoy stick was MBR. Thinking it was just a one off quirk, I re-formatted it with GPT and the issue remained.
Try resetting the BIOS settings to defaults. When updating a BIOS, the new BIOS can misinterpret the old BIOS settings. Resetting to defaults ensures that the saved BIOS settings match the new BIOS.
MSI's embedded M-Flash resets the BIOS to defaults automatically after every flash update as well as deletes any saved profiles. It's quite frustrating, actually! LOL

I have to manually re-configure EVERYTHING ... boot order, wake events, post beep, TMP, Secure Boot, XMP ... lots of reboots and memory training. :\
Just reporting that the same issue happens with YUMI ExFat which is based on Ventoy. I'm gonna clear CMOS in a few days just to see if it helps. Afterwards, I'll test if the issue persists from a factory default state (i.e no XMP, no tweaks) and report back. I don't think my BIOS is corrupt since the BIOS is fine without a Ventoy based USB stick inserted, but it's clear there's a possible memory leak being triggered and the common denominator seems to be ExFat partitions or my RAM ...

UPDATE: I forgot all about this video I made back on October 25th. As you can see, the Ventoy stick is inserted into a USB port (indicated in the boot order by a brighter shade of white) and no language corruption. This is all on a BETA version of their August BIOS. 

Okay, so here's an update ... when the AA1 BIOS for this board was published, it was in Beta. Some time after, MSI took the BIOS out of Beta and the assumption there was they just renamed the BIOS file by changing the 1 into a 0 since the build date is the same. Out of curiosity last night, I downloaded that BIOS update and compared it with the BETA version using an MD5 tool. The hashes did NOT match. Same build date and all. But no way to tell which BIOS really supersedes the other because MSI engineers just don't think a detailed changelog explaining the differences and what was fixed in between is sufficient. That's bad form. Even the most mundane bugs, incompatibilities, and fixes should be documented ...

So moments ago, I updated my BETA BIOS with this Release BIOS, and after the CMOS was automatically cleared, I only enabled XMP, POST Beep, and Wake Events for USB and PS2. Saved. Rebooted. Went back into BIOS to verify XMP was working, inserted my Ventoy stick, and rebooted to see if the language corruption bug happened. It did not. With the Ventoy stick inserted at 96% BIOS defaults, the language is unaffected. This does NOT mean the problem is solved, per se. It means that a specific setting or combination of settings triggered this bug in the BETA and could still be present in the release and now I've gotta go back and narrow them down. 

Here's the shortlist to the best of my memory:

XHCI was Disabled. (Currently Enabled)
Hot Plug for all SATA was Enabled. (Currently Disabled)
PCI Gen for M.2 slots was set to Gen4/Gen3 respectively (Currently Auto)

I had these settings in the BETA because it seemed to help my Elecom USB Trackball be more responsive.
I'll monitor its behavior today and try to trigger the language corruption bug again by reverting my settings one by one ...

Forum Jump:

Users browsing this thread: 1 Guest(s)