Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Legacy BIOS doesn't boot with exFAT
I created my first Ventoy USB stick the other day, and while everything worked perfectly in UEFI, it just wouldn't boot in Legacy BIOS. I tested in VMware, VirtualBox, and my actual system and i got the same result with all of 'em... a blinking cursor on the top left of the screen.

I couldn't figure out what the issue was.. tried everything but still won't boot. In the end i decided to reformat the main ventoy partition with NTFS instead of exFAT, and hoped i got lucky... lo and behold it now boots successfuly with legacy BIOS!

Anyone know why it doesn't boot with exFAT? Btw i have a 2GB reserve partition formatted as FAT32, not sure if that made a difference.
What partition type - Legacy\BIOS or GPT?
It should legacy boot in VBox. I dont have a problem and no one else has reported such a serious problem as the default format is exFAT.
Maybe something went wrong when you made it or maybe you have a faulty USB drive?
MBR type. All i did was reformat the partition as NTFS and it worked. I kept the same partition layout and copied the exact same files to the drive. I didn't change the ventoy config either. Could be a faulty drive i don't know, didn't try a different one. But as i mentioned before, with UEFI it works fine, only in legacy BIOS it refused to boot.
Did you also add the 2GB FAT32 partition again on the NTFS drive?

Can you remake the drive again and try to reproduce the issue but do not change the partitions at all after making the drive?

Forum Jump:

Users browsing this thread: 1 Guest(s)