Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Failure when booting Ububtu 20.04 in Secure Boot
I am running Ventoy 1.0.53.

I just got my Ventoy USB drive working with Secure Boot. It was painful to get the MOK keys registered, but I finally figured out a work-around (Not Ventoy's issue, I know).

Now that I have my Ventoy USB working with Secure Boot, I started trying out all my ISO images to see how they ran.

I ran into a problem with my Ubuntu 20.04 ISO with a persistent image enabled.

When booting Ubuntu 20.04, I saw the following MOKManager failure:

Verification failed: (0x1A) Security Violation

Is this a known issue with Ubuntu and Secure Boot?


The same error without persistent enabled?
Hi, @longpanda - Sorry I didn't respond back earlier. I didn't get an email that you had asked your question.

The same error occurs without persistence enabled. I put an Ubuntu 18.04 LiveUSB ISO image onto my Ventoy USB drive, and saw the same error pop up.

I found something new to add about this issue, though.

While I saw the same Verification failed: (0x1A) Security Violation MOK error occur for both the 20.04 persistent image and the 18.04 non-persistent image, I tried something I wouldn't normally do: I decided to try hitting "ESC" each time I saw the MOK error, and both images would successfully boot to Ubuntu after the 4th failure message > ESC key press.


Forum Jump:

Users browsing this thread: 1 Guest(s)