Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
【Solved】Issue with menu_alias and Multi-Mode Option
I created two sections in ventoy.json, menu_alias_uefi and menu_alias_legacy.
I separated legacy and uefi isos based on each section.
All isos show up in the menu, no matter what mode I am in.
How can I solve this?
Please give your ventoy.json and some photos.
I am not sure how to make uefi bootable isos only to be visible under uefi boot and legacy isos to show up only under legacy boot.

Pictures of Legacy and Uefi



    "control_legacy" : [
    "control_uefi" : [

For example:

Put ISO files that only for legacy BIOS/UEFI  mode in the directory DIR_TEST_LEGACY/DIR_TEST_UEFI
Thanks for the suggestion.
What about isos that can boot in both uefi and legacy? 
Will I need to have two copies of the same iso in both folders?

Maybe a plugin or a control option that will not display isos if they are listed under menu_alias?
Yes, You need two copy.

Or, you can use image_list plugin.

    "image_list_legacy": [
    "image_list_uefi": [
Quote:Yes, You need two copy.

Not a very good solution.

Tried image_list plugin. Works well, however I still would like one folder, say /iso/Auto, where isos images can
be tested very fast without modifying ventoy.json each time and adding new path to image list.

Then I looked at image_blacklist. I thought with this plugin, ventoy will search and display all images not found in the
image_blacklist section as per documentation "Firstly, Ventoy will search as normal. And then remove the files in the blacklist from the search result."

This doesn't seem to work for me for some reason.
First of all, it seems to work in reverse. image_blacklist_uefi should contain legacy images and image_blacklist_legacy should contain uefi images.
Secondly, Ventoy doesn't display any images not found in the image_blacklist. 

Is this a bug or am I doing something wrong?

    "image_blacklist_uefi": [
    "image_blacklist_legacy": [
It's a bug. I have fixed it, please use the CI release for test:
Thank you.

I can confirm that image_blacklist works as it should.

Forum Jump:

Users browsing this thread: 1 Guest(s)