Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
unable to boot from disk
I recently found that the modem port inside my Lenovo T14 AMD can be used to host an NVMe drive, too, and decided to use it as an emergency drive containing several ISOs and the like in order to rescue anything if necessary - sysrescd, kali, ubuntu, ...

So I got me Ventoy 1.0.35 and unpacked the tar on my Linuxmint OS, fired up a terminal and ran 
sudo ./ -i -s -g /dev/nvme1n1

Then I enrolled the necessary key using 

sudo mokutil --import ENROLL_THIS_KEY_IN_MOKMANAGER.cer

and copied some ISOs to the Ventoy partition. Then I rebooted in order to verify the enrollment. After completing it I rebooted and opened the boot device list. My Linuxmint drive was listed as 'ubuntu' and started up like before, but the Ventoy disk was displayed only with its manufacturer and model. Nevertheless I selected it and tried to boot into ventoy - but to no avail.

Since I ended up with Grub 2.02 command line (and my Linuxmint uses Grub 2.04) I think I was in the correct location.
I tried to load the Grub config, but this only resulted in an error
error: cannot find command vt_list_img
being displayed and then a strangely looking grub menu came up, telling me that no ISO could be found.

Obviously something is wrong - but I'm a bit lost for now.

Any hint anyone?
Ventoy use grub 2.04 not 2.02. Some video may be helpful.
Thx for telling. I'll try to get some footage.

One more thing - looking into parted the Ventoy disk has no partitions marked for boot. Shall I make the hidden partition bootable? Where's grub bootloader installed - in the MBR of the disk? of the partition? I'm a PC dinosaur familiar with BIOS, but not UEFI
Secure Boot is the hardest thing to ever get working correctly lots of extra work is needed to maintain. It really seems to only provide protection from a really small number of threats. If your careful Secure Boot is not needed. Infact if it ever did get used and took effect your computer would become unusable anyways requiring a reinstall of your boot loader and removal of any unsigned modules and drivers.

I recommend setup without Secure boot and you will most likely have better success.
Secure boot has been turned off after obtaining the laptop, but UEFI can't be switched to legacy BIOS anymore on this machine - Lenovo is phasing this option out Undecided

Too bad it's next to mandatory now, especially when it's not as protective as it is advertised ...
Make sure the Nvme is not setup on any RAID mode that seems to always mess things up. Infact I can't even use my Nvme unless I take it out of raid on my Dell xps.
husky Wrote: UEFI can't be switched to legacy BIOS anymore on this machine - Lenovo is phasing this option out Undecided

I was going to suggest switching to core/libreboot (that's what I run on my X220), but I couldn't find one for your particular model...
Idea When a post helps you in any way, please rate it. Thank you. [Image: rateit.png]

Forum Jump:

Users browsing this thread: 1 Guest(s)