Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Ventoy USB multiboot stuck at "Loading Hardware Specific Modules" on a DT
Hi, I'm no expert in Ventoy or Linux, but I've been getting acquainted with them since a couple of years ago. One way of accomplishing that is by setting a Ventoy multiboot USB flash drive.

Most often I've been playing with MX-Linux 19.3 KDE x64 with 16 GB Persistence dat file, and so far so good saving lots of data files in the dat virtual storage for a couple of months until, I guess, I made a terrible mistake and started getting stuck at the message of the Subject above...

I have already posted in a MX Linux forum, but I was advised rather to post in a Ventoy forum.

This is how it all started:

A few days ago the system was left on for a day or two, with an extra empty flash drive attached to another USB port, when I set the system to Suspend mode in order to save a little in the electric bill, and get the system back quicker and right where it was before going to Suspend mode. Prior to turning the system back on in the day after, I decided first to replace the extra flash drive by another one, as it was not yet being used by me after all...

As a matter of fact, my guess is the system does save all current status information in regards the hardware, software, RAM and so on when going to Suspend mode, quite different from when going to shut down, of course.

Besides, now I can not either boot any other Linux in the Ventoy flash drive, neither using or not using the Persistence dat file for the MX Linux, or for any other flavor for that matter. Even the boot order in the BIOS settings has being changed intermittently for some reason beyond my reasoning.

The screen where the message is displayed is a blank one. Hitting Enter takes the cursor down like a new line (wrap). Alt-F2/F3... does not work either. Nothing can be done.

I'm writing this topic on a dual boot W7/Debian Buster, and using Dolphin I can browse the ISO and dat files in the Ventoy USB multi boot flash drive, but no any other files seen there.

I deeply appreciate if anybody knows how to address this and get the Ventoy flash drive usable again without losing any information stored in it. And, of course, without starting fresh from scratch again.

Not to mention it is a good challenge and opportunity to learn something else out of it.

Let me know of any other additional detail you might need to resolve this issue.

I can use an hex editor to do changes in the right spot if someone tells me how.

See dropbox link of the screenshots here.
OSes: Debian Buster, Ventoy Multi Boot USB with Persistence with Linux Lite, Manjaro, MX Linux, Ubuntu Studio, Zorin and others
HW: ASUS TUF X570-Pro, AMD Ryzen 9 5900X 12-Core, 4200 Mhz, 128 GB RAM, SAMSUNG 980 PRO 2TB PCIe NVMe Gen4 SSD M.2, Intel® Eth Ctler I225-V, Logitech K520 / M510

Messages In This Thread
[SOLVED] Ventoy USB multiboot stuck at "Loading Hardware Specific Modules" on a DT - by Plurix - 02-15-2021, 10:36 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)