Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Persistence with Ventoy 1.29 and Mint 20
I successfully had persistence working with an earlier version of ventoy and Mint 20 but now with Ventoy 1.29 it does not seem to work .
Here is my json file. If I check under tools using the F5 key on boot it says persistence is working but files do not seem to persist after a reboot
    "persistence" : [
            "image": "/ISO/linuxmint-20-cinnamon-64bit.iso",
            "backend": "/Persistence/Mint-Persist.dat",
            "autosel": 1
Please do some Comparison test.
For example:
1. update to 1.0.30 and test
2. update to 1.0.25 (? your old version) and test.
3. update to 1.0.29 and test
4. re-create a new persistence.dat file and test
$ sudo sh -l Mint-Persist.dat
[sudo] password for david:         
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB, 1.0 GiB) copied, 1.96581 s, 546 MB/s
mke2fs 1.45.5 (07-Jan-2020)
Creating filesystem with 262144 4k blocks and 65536 inodes
Filesystem UUID: cc5ff620-fc0b-4c4d-a1b9-14c8855698a9
Superblock backups stored on blocks:
    32768, 98304, 163840, 229376

Allocating group tables: done                           
Writing inode tables: done                           
Creating journal (8192 blocks): done
Writing superblocks and filesystem accounting information: done
OK I have tried all the steps except updating to 1.0.30. I know assurances have made that there is no malware in it despite malware showing up on Virus Total but I need to be certain.

When I recreate the dat file which I labelled Mint-Persist.dat the file is not renamed but remains persistence.dat. I manually named it. Is that a mistake on my part?
You confuse two concepts. One is persistence file name,  another is the label of the filesystem inside the persistence file.
The file name of the persistence file doesn't matter, you can rename it to xxx.dat  abc.dat  123.dat ......

But the label of the filesystem inside the persistence file is very important and MUST be set as noted in the table here:

So the persistence dat file created by you is invalid and can NOT be used by Linux-Mint.
You should create as follows (without -l option or with -l casper-rw option):  

sudo sh
sudo sh -l casper-rw

casper-rw is the only valid label for linux-mint.
Thank you for your help. It's working fine now Smile

Forum Jump:

Users browsing this thread: 2 Guest(s)