Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ubuntu persistence version 20.04 in legacy mode

I want to use the persistence for ubuntu in version 20.04 installed in legacy mode.

I have tried a few times to make it work without success.

Today I updated to version v30. It still doesn't work in my context.

Here is the content of my persistence file.

"persistence" : [
    {"image": "/ISO/ubuntu-18.04.1-desktop-amd64.iso", "backend": ["/persistence/18.04-OrdiA.PER", "/persistence/P19.PER"  ] },
    {"image": "/ISO/ubuntu-20.04.1-desktop-amd64.iso", "backend": [ "/persistence/20.04.dat"  ]  } ],
"conf_replace_legacy": [
{ "iso": "/ISO/ubuntu-20.04.1-desktop-amd64.iso", "org": "/isolinux/txt.cfg", "new": "/Menus/txt-20.1.cfg"},
{ "iso": "/ISO/ubuntu-18.04.5-desktop-amd64.iso", "org": "/isolinux/txt.cfg", "new": "/Menus/txt-18.5.cfg"},
{ "iso": "/ISO/ubuntu-18.04.1-desktop-amd64.iso", "org": "/isolinux/txt.cfg", "new": "/Menus/txt-18.1.cfg"} ]

It is verified.!AobnjnjPuoUqmQHJIRR1..._?e=74iOus

Here is the content of my personalized order line

For the first try
label montest
  menu label ^Essayer Ubuntu sans installation avec mes modifications
  kernel /casper/vmlinuz
  append  file=/cdrom/preseed/ubuntu.seed initrd=/casper/initrd nomodeset vga=0x31B---

then for the second try
label montest
  menu label ^Essayer Ubuntu sans installation avec mes modifications
  kernel /casper/vmlinuz
  append  file=/cdrom/preseed/ubuntu.seed initrd=/casper/initrd nomodeset persistent vga=0x31B---

Regardless of the context, initramfs does not find persistence and refuses to work.

===>    CRASH!   "can not mount /dev/disk/by-label/casoer-rw on  /cow"!AobnjnjPuoUqmQLUICoi...J?e=gsLmLw

The persistence file has also been recreated today but no change.

I still have to choose non-persistence mode and install the boot-repair software to boot with the installation media

Can you guide me?
Thank you.
Is the volume name of the persistence file casper-rw?
How did you make it?
When use persistence you don't need to replace the config file to add some persistence boot option.
So just use
    "persistence" : [
            "image": "/ISO/ubuntu-20.04.1-desktop-amd64.iso",

and make a try.

1. does it prompt you to select to boot with or without persistence data when you select the ISO to boot?
2. How did you make the persistence data file?

The startup problem is resolved.

However, I thought I had made the persistence file correctly.

The software I'm using forgot to tell me that I have to prefix it with the word sudo (it should know how to warn.)

And I did not realize that the reported anomaly was extremely serious!

a@b:~/ventoy-1.0.30$ ./ -s 4000
4000+0 enregistrements lus
4000+0 enregistrements écrits
4194304000 octets (4,2 GB, 3,9 GiB) copiés, 19,8929 s, 211 MB/s
losetup: /dev/loop15 : échec de configuration du périphérique boucle: Permission non accordée
mke2fs 1.45.5 (07-Jan-2020)
Impossible d'ouvrir /dev/loop15 : Permission non accordée
losetup: /dev/loop15 : échec de détachement: Permission non accordée

Now that it works, I find that the boot is extremely long

ubuntu@ubuntu:/mnt/home/a/Bureau$ sudo systemd-analyze time
Startup finished in 2min 46.921s (kernel) + 18min 38.759s (userspace) = 21min 25.680s reached after 18min 37.125s in userspace

ubuntu@ubuntu:/mnt/home/a/Bureau$ systemd-analyze blame | head -10
18min 4.416s ubiquity.service                                                        
4min 45.260s systemd-tmpfiles-clean.service                                          
1min 28.947s dev-mapper-ventoy.device                                                
     29.399s snapd.hold.service                                                      
     12.665s NetworkManager-wait-online.service                                      
     10.629s snapd.service                                                           
     10.506s gdm.service                                                             
      8.790s snapd.seeded.service                                                    
      7.237s systemd-udev-settle.service                                             
      6.421s accounts-daemon.service                                                 

especially if I compare it to a build with unetbootin in a dedicated partition

ubuntu@ubuntu:~$ df -text4
Filesystem     1K-blocks   Used Available Use% Mounted on
/dev/sdd2        1037616 364008    602852  38% /media/ubuntu/casper-rw

ubuntu@ubuntu:~$ sudo systemd-analyze time
Startup finished in 2min 46.514s (kernel) + 25.690s (userspace) = 3min 12.205s reached after 25.524s in userspace

ubuntu@ubuntu:~$ systemd-analyze blame | head -10
10.698s gdm.service                                       
5.769s systemd-udev-settle.service                       
5.596s dev-sdd1.device                                   
4.626s snapd.service                                     
4.182s NetworkManager-wait-online.service                
4.119s udisks2.service                                   
3.816s dev-loop0.device                                  
2.533s accounts-daemon.service                
2.254s avahi-daemon.service                              
2.149s NetworkManager.service                            

I noticed that the first one uses

while the second uses

But I don't understand the reason; Do you have an idea?

Forum Jump:

Users browsing this thread: 1 Guest(s)