Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux Live Kit compatibility issue?
I'm not sure whether this is an issue with Ventoy or Linux Live Kit or somehow Mint, but here's what I did:

I customized Linux Mint by making an ISO of my hard drive using Linux Live Kit.  It generated an ISO file and a ZIP file.  I tried placing the ISO file onto my Ventoy drive and booting into it, but it didn't work.  First it booted Ventoy, and then gave me the menu to boot Mint, but when I did, it said that it's may not be compatible with 64-bit EUFI (It's a generic error that I've seen before, and it's common when I try to boot some ISO files on Ventoy but it never happened with Mint before, and why wouldn't it be compatible, considering that it was made from a 64-bit OS which I regularly boot in UEFI mode?).

So then I switched to CSM (Legacy BIOS) mode, and booted it again.  This time it showed a bunch of scrolling text like usual, but then it said:

Live Kit init (followed by a link to their website)
Setting Dynamic RAM compression using ZRAM if available
Probing for hardware
Looking for linux data in /linux.............................................................
Fatal error occurred - Could not locate linux data
Something went wrong and we can't continue.  This should never happen.
Please reboot your computer with Ctrl+Alt+Delete...

It should be noted that when I generated the ISO file, Live Kit told me an error that it couldn't find /linuz, so I went into the config file and changed a line to say /boot/linuz (because that's where it really is), and then it worked fine and created the ISO file without any errors.
Please test your ISO file with a virtual machine (e.g. VirtualBox or Vmware) firstly to confirm that the ISO file can boot fine in a VM.
Oh, that's a good idea, thanks!  I don't know why I hadn't thought of that.


I've tried it in VirtualBox now, and the ISO boots and runs, so I know it's a valid ISO file, but it did act a bit strangely:

First, when it got to the end of the text display, just before showing a graphical one, it briefly had displayed a prompt to login (which isn't unusual) but then it briefly displayed an error related to logging in (which I haven't seen before).  Then it showed the graphical login screen and allowed me to proceed.

But once I was in Mint, I tried to open a Java file and it didn't open - double-clicking did nothing.  And when I typed Java -version it said it couldn't find Java at all, even though Java 11 comes included with Mint 20, and I'm CERTAIN that I had installed Java 1.8 (for compatibility with JavaFX) before I made the ISO, because I had even tested it!  And the icons have the Java image, and when I choose Open With it gives me the option of Java 11, but choosing it still doesn't open the program, and I can't figure out why!

Has anyone ever had this problem?  Could it be because I installed it in a folder in root rather than in Home, and maybe that doesn't get carried over into the live ISO?  It seemed like the folder disappeared.  But then, Java 11 should still be there, and even Mono worked fine!

But to answer your question, yes, it sort of works in VirtualBox, but despite that, it still won't boot in Ventoy.


Here's some more information which may help with diagnosing the issue.  I tried to burn the ISO onto a drive and run the script included with Live Kit to make the drive bootable, but I got an error that said it didn't recognize the file system.  I checked and it was something like ISO9660 (that might not be the exact number), so I reformatted it as EXT4 and extracted the contents of the ZIP file (which is identical to the ISO) onto the drive instead of using the ISO, and ran the script and it worked fine and booted (though I had to switch to Legacy BIOS/CSM mode).

So basically, it seems that the ISO has a weird file system built into it.  Could that be the problem?  Might I try to recreate the ISO from a working drive built from the ZIP file onto an EXT4 file system?  I'll look into a way to do that and see if it works, but if anyone knows any reason why this would cause problems I'd very much like to know.  Also, if anyone has any suggestions about Java that would be great too, because I MUST get that working!

Forum Jump:

Users browsing this thread: 1 Guest(s)