Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 Ventoy does not work on Seagate 4TB HDD - Solved
(02-04-2023, 04:43 AM)crasadure Wrote: Legacy BIOS Access Range Limitation
Pls check this article sir,

Workaround 1 (Recommend)

You can preserve some space at the end of the disk. We can make use of this feature, to preserve some space at the end of the disk and to "extrusion" Ventoy's part1 and part2 within the BIOS's access range. Take a 256GB USB drive for example, if the BIOS access limitation is 137GB, we can preserve 150GB space when install Ventoy. So the part1 and part2 of Ventoy will be at the first 106GB space and will not trigger the BIOS's limitation. Please refer Notes for detailed information of the feature.

Workaround 2Reformat the 1st partition manually (NTFS/exFAT ...)

To make sure that the file in step 2 will be saved within the BIOS access range.

Copy ventoy.disk.img.xz to the 1st partition

Get ventoy.disk.img.xz from the install package (under ventoy directory). Create a ventoy directory in the 1st partition and copy ventoy.disk.img.xz into it.

That's /ventoy/ventoy.disk.img.xz in the 1st partition.

Notes For Workaround 2

It should be noted that, this is just a workaround. There is no software solution for the BIOS limitation. If all the ISO files are within the valid range, there will be no problem. But if you put many many ISO files to the USB disk and some of them will be out of the range. For these ISO files, BIOS can't read them and there will definitely be problems when boot them.

Extra benefits for workaround 2
Just for Legacy BIOS mode, although workaround 2 is used for the limitation of the BIOS, but it can also be used to avoid the situation where the data of the 2nd partition is damaged. Because the workaround proces is to get data from the file mentioned above when failed to access the 2nd partition. The access failure may be due to the limitation of the BIOS, or the file may be damaged.

1.What is your motherboard brand/model?
2.What is your motherboard bios version?
3.İs it support 4tb external hard drive?
4.İs your motherboard support Uefi?


I have already managed to run Ventoy on my 4TB Seagate disk, I have used solution 1, I have created a free space of 3.9 TB and the rest about 80GB I have used for the 2 partitions of Ventoy in GTP mode, and starts the Ventoy Grub and I see the installation and recovery ISOs I have in the Ventoy partition and the rest until the 4TB is for copies on the external disk .
Thank you very much for your help, it cost me a little bit to understand it because of the language problem, but that's it Smile Heart

I mark the thread as "Solved"

P.S.: Angry
ISOs are seen, but with my 2016 motherboard (Gigabyte 970A-DS3P) some ISOs do not boot, almost all Linux ISOs or created with Linux systems, Windows ISOs do boot....
On the other hand a more modern motherboard like the one in my laptop (Lenovo IdeaPad 3 15ALC6) they all boot without problems.

Translated with (free version)

Messages In This Thread
RE: Ventoy does not work on Seagate 4TB HDD - by Senpai - 02-06-2023, 11:41 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)