Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Drive not recognized in legacy mode?
(12-01-2020, 08:54 PM)Steve2926 Wrote: What is the size of the hard drive and how are the partitions arranged?
Does the disk have MBR partitions or GPT partitions?
What is the system and what is it's age (mainboard and BIOS revision)?
As an experiment, you could try deleting the second partition on the USB hard disk, just to see if an MBR boot option is then listed.

Thank you for your interest.
I got a bunch of additional info but I will answer this first just for clarity' s sake.

The intended HDD drive is an 320GB HDD, but the same happens on an 1 TB drive. I also have a 500GB HDD booting to GRUB without issues.

I only tried the MBR scheme, and I am letting Ventoy do it process. On the 320 GB drive I used the whole disc, but in recent tests with the 1 TB drive I told Ventoy to spare half of the total space.

This is a Lenovo B40-70, BIOS 9DCN29WW v2.09. I am not too  inclined to flash it to be honest.

Deleting the UEFI partition didn't help, but more info on that in my next post.... ->

ok, so this is getting weird now .D …

After many tests and reformats I've found that the only scenario in which I can boot an USB HDD in Legacy BIOS in this laptop is when I also have either one of two specific bootable pendrives attached....

I have two crappy HP v165w bootable pendrives, and only when any of them is attached the Ventoy drive shows as available and I can boot from it...

How odd is that?!?!

One of these pendrives is MBR and the other one is GPT, so that doesn`t seem to make a difference.

Swapping HDDs, enclosures or any of the many bootable sticks I tried didn't make a difference either.

Interestingly, using a 120GB SSD in this very same enclosure did work...
And the original HDD and enclosure on a different laptop worked too...

So it seems to me that, for some reason, 'this laptop will not boot a Ventoy drive in BIOS mode when it is an HDD disc', but it will boot from it if it's a stick, or an SDD, or UEFI, or any of these but on a different computer...

My guts "tell me" this might be related to A) the laptop no liking the blank space before the first partition and ignoring the device a bootable medium, or B) the HP sticks create at slight delay at boot that allows/forces the BIOS to find the Ventoy drive as bootable.

I guess this is probably a very edge situation and not worth investing dev time in it.

Some additional notes, FWIW:

- This could also be related to USB-HDD/USB-ZIP/USB-FDD modes? But I haven't found way to determine what mode is being detected on each drive.

- When both the stick and the HDD are attached, they are both properly listed as bootable (one BIOS and one UEFI entry for each drive)

- No change resulted from deleting the UEFI partition at Ventoy nor from changing the ISOs partition from exFAT to NTFS.

- Unfortunately I am not too keen of flashing the laptop's BIOS to see if that fixes it.


[Edit: The board system is not allowing me to post as two separate messages as I'd like, so all together it is..., sorry]

Messages In This Thread
RE: Drive not recognized in legacy mode? - by Ren - 11-30-2020, 06:13 PM
RE: Drive not recognized in legacy mode? - by Ren - 12-05-2020, 11:44 PM
RE: Drive not recognized in legacy mode? - by Ren - 12-14-2020, 12:56 AM
- - by Brandonbog - 12-14-2020, 03:34 PM
RE: Drive not recognized in legacy mode? - by Ren - 12-27-2020, 06:26 PM

Forum Jump:

Users browsing this thread: 2 Guest(s)