Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ventoy on Linux - need to format usb stick as ext3/4
Dear all,

After numerous attempts with various programs to create a working multiboot usb stick, I finally succeeded with Ventoy. So I thank and congratulate the author for providing an excellent piece of software.

I am working on linux (mainly Mint 18), on an Asus CM6330 desktop with an intel i7 cpu, dating from 2012. I eventually used a new Sandisk Ultra 32 GB usb stick.

One problem which I had to overcome to get Ventoy working effectively was to format the main partition on the usb stick as ext3 (using Gparted), after installing Ventoy on the stick. If the default fat format of the partition was used, I could copy isos to the stick, and activate the Ventoy menu when booting, but no iso would load (whether in legacy or uefi mode). It is possible that the problem is limited to some rather old machines, but I suggest that the Ventoy documentation should indicate the desirability for linux users of formatting the main partition on the usb stick as ext3 after installing Ventoy on the stick.

Best wishes,
Peter Stone
Is it OK if you don't format the main partition to ext3? (default is exfat).
(10-14-2020, 11:46 AM)longpanda Wrote: Is it OK if you don't format the main partition to ext3? (default is exfat).

No, with exfat I could copy isos onto the partition, and could boot into the ventoy menu. But nothing would boot from there. The attempts hung, with a cursor in the top left corner of the screen.

Finally I got the idea that it might be the partition format, and so I reformatted the partition as ext3 (using Gparted). Then I copied the isos on to it, and EVERYTHING WORKED! (I chose ext3 because it is a well established linux format, and because ext4 might have been more demanding. But my prediction is that ext4 would also work.)

I was especially pleased as for a few days I had tried various programs (such as Yumi), as well as Ventoy. Only Ventoy has worked for me.

All the isos used were of linux distributions or tools. I did not try to put a Windows iso or toolkit on the partition.

I now have the multiboot stick which I wished to create. But I am willing to do some further experimentation, if that would help development of the program.

Best wishes,
Peter Stone
When you use the default exfat file system please make sure that you wait the cache flushed to the USB before you reboot or plug-out the USB drive.
Or you can do this:
1. Copy the ISO file to the USB drive.
2. run sync cmd
3. plug-out the USB drive
4. plug-in the USB drive
5. md5sum the ISO file in the USB drive to make sure that the ISO file is right
6. reboot and test again.

Forum Jump:

Users browsing this thread: 1 Guest(s)