Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 Issues with PXE Boot on Hyper-V Gen1 Virtual Machines

My use case for iVentoy is to manage and install Virtual Machines in my Hyper-V lab configuration. Unfortunately, everything I have tried with these Gen1 Hyper-V machines running a Legacy BIOS have been unsuccessful in booting iVentoy, I believe the issue is with iVentoy but I'm happy to troubleshoot further.

Additionally, I am able to EFI boot my iVentoy configuration on both my Hyper-V Gen2 Lab VMs, and my own personal computer outside of the lab environment is also able to EFI boot.

I've tried numerous options in the configuration, switching to a lower resolution, swapping to CLI - unfortunately does not work.

The iVentoy console is able to see the Hyper-V machine, but is not able to get past HTTP start 200 [/ipxe/01-00-15-5d-01-17-10]

The best description of the error message is " Could not configure console. " which when searching this forum, I did find some references to it with how the solution is compiled or something along those lines and some older devices losing compatibility along the way.

I believe this issue should be repeatable by anyone running Windows 10/11 Pro or above and using the Hyper-V service that is included with the Operating System to simply create a Gen1 Virtual Machine with any specs and attempting to LAN boot (assuming your machine is also bridged to your local network or able to connect to iVentoy depending on your network).

I've attached two screenshots - the machines that are mentioned in the console are both throw-away test Virtual Machines I've created under Hyper-V.

Thank you for your assistance

Error tags:
Could not configure console.

Edit: If attachments are not loading, please see links below

Edit 2: Here are some additional resources and reports I found on the forum of people reporting similar issues, I'd be very happy to assist in troubleshooting here and getting this resolved once and for all.

Attached Files Thumbnail(s)
I've also found these threads that might prove useful in troubleshooting, but need some assistance on how you'd like me to assist with debugging. I would like to assist with troubleshooting and debugging on my end to help resolve this issue for a future release, thank you.

Forum Jump:

Users browsing this thread: 1 Guest(s)