Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Boot direct to Vdisk
#1
Using this ventoy_grub.cfg:

Code:
menuentry "Boot Mint (Xfce)" {   
    set my_vdisk_path="/Virtualbox/LinuxMint(Xfce).vdi.vtoy"
   
    if search -n -s vdiskhd -f "$my_vdisk_path"; then
        vtoyboot_common_func "($vdiskhd)$my_vdisk_path"
    else
        echo "$my_vdisk_path not found"
    fi
}

then after the first menu loads, which says it couldn't find any ISOs, I can press F6 and then boot my vdisk from there, either from the USB stick or the computer's HDD (which is obviously faster). That works but I want to skip straight to the second menu.

I created this ventoy.json:

Code:
{
    "control": [
        { "VTOY_DEFAULT_MENU_MODE": "0" },
        { "VTOY_FILT_DOT_UNDERSCORE_FILE": "1" },
        { "VTOY_SORT_CASE_SENSITIVE": "0" },
        { "VTOY_MAX_SEARCH_LEVEL": "1" },
        { "VTOY_MENU_TIMEOUT": "10" },
        { "VTOY_DEFAULT_KBD_LAYOUT": "QWERTY_UK" },
        { "VTOY_FILE_FLT_VTOY": "1" },
        { "VTOY_DEFAULT_IMAGE": "/Virtualbox/LinuxMint(Xfce).vdi.vtoy" },
    ],
   
   "image_list": [
    "/Virtualbox/LinuxMint(Xfce).vdi.vtoy"
    "/Virtualbox/LinuxMint(MATE).vdi.vtoy"
    ]
}


but it says "syntax error detected" when I boot with that. Can anyone see what's wrong?

Also, I'd like to try booting my vdisk on my PC from my grub4dos boot menu, without needing to use a USB stick, but it seems I need vdiskchain and it doesn't seem to be available anywhere to download, only if you can compile it using the files here https://github.com/ventoy/vdiskchain which I don't know how to do. Is there anywhere I can download it?
Reply
#2
Ah, I feel a bit stupid, now I see that the compiled vdiskchain is here https://github.com/ventoy/vdiskchain/releases/tag/v1.3

I'm still not sure why my ventoy.json isn't working. I removed the "image_list" section, so it now looks like this:

Code:
{
    "control": [
        { "VTOY_DEFAULT_MENU_MODE": "0" },
        { "VTOY_FILT_DOT_UNDERSCORE_FILE": "1" },
        { "VTOY_SORT_CASE_SENSITIVE": "0" },
        { "VTOY_MAX_SEARCH_LEVEL": "1" },
        { "VTOY_MENU_TIMEOUT": "10" },
        { "VTOY_DEFAULT_KBD_LAYOUT": "QWERTY_UK" },
        { "VTOY_FILE_FLT_VTOY": "1" },
        { "VTOY_DEFAULT_IMAGE": "/Virtualbox/LinuxMint(Xfce).vdi.vtoy" }
    ]
}

and I don't get a syntax error anymore but it doesn't have any effect and it still boots to the "Couldn't find any ISOs" screen and I have to press F6 to load my custom menu and then select the (only) entry there to boot the vtoy file.
Reply
#3
{ "VTOY_FILE_FLT_VTOY": "1" },  
You misunderstood this option.
Set it to "1" means that filt .vtoy files (doesn't show .vtoy files).
So just delete this line.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)