Ventoy Forums
老大,不能升级(15、16版)(待确认) - Printable Version

+- Ventoy Forums (https://forums.ventoy.net)
+-- Forum: Ventoy General Use (https://forums.ventoy.net/forumdisplay.php?fid=1)
+--- Forum: Ventoy Discussion Forum (https://forums.ventoy.net/forumdisplay.php?fid=2)
+--- Thread: 老大,不能升级(15、16版)(待确认) (/showthread.php?tid=399)



老大,不能升级(15、16版)(待确认) - sunsky - 07-24-2020

14版没有问题,15版开始只能重新安装,16版也是一样

15版,16版,都可以升级到14版,但其他版本,不能升级到15或16版

试过几个U盘,移动硬盘也是一样。

其他朋友有这个问题吗?


RE: 老大,真的不能升级,新版的 - longpanda - 07-24-2020

你还能重现这个问题吗?
具体点说,比如先安装哪个版本? (11/12/13 ?) 然后再打开15/16版本无法升级。


RE: 老大,真的不能升级,新版的 - sunsky - 07-24-2020

我截了图,15和16版的升级按钮是灰色的,其他版本,是正常的,我分别用我的,64G  sandisk U盘 和500G移动硬盘试的,具体先装的那个版本有点记不清了。我还有一个128G的U盘好像也是这样,没在身边。

[attachment=144]

我把我的64G U盘重新安装10版,现在可以升级了。

应该是从以前版本升级的问题吗?

我的500G硬盘也格式化了,先装的09,又可以升级成16版了。


RE: 老大,不能升级(15、16版)(待确认) - longpanda - 07-24-2020

正常来讲,如果Ventoy检测不到U盘内的版本号,升级按钮就应该置灰。 在15版本之前,这个没有严格执行。 从15版本之后检查严格了。
只要检测不到版本号,就不能升级。 这个是对的,因为你对一个新U盘,直接执行升级操作是会出问题的。

如果你U盘里面已经安装了Ventoy,但是检测不出版本号,则是另外的问题了。 说明Ventoy在兼容性这块哪个版本有问题。
这个需要结合log来看。


RE: 老大,不能升级(15、16版)(待确认) - sunsky - 07-24-2020

我的盘中安装了以前的版本,不能升级。现在重新安装就可以了。


RE: 老大,不能升级(15、16版)(待确认) - Van Flusen - 07-24-2020

This problem has already been mentioned here:

https://forums.ventoy.net/showthread.php?tid=349


RE: 老大,不能升级(15、16版)(待确认) - sunsky - 07-25-2020

从15版开始,内部版本号后面增加了MBR标记,这个是新加的设置?
是否不能升级与这个有关?14版以前没有这个标记。

这个帖子我见过,当时我也是这个情况,我以为是偶尔的原因,不想升级到16新版本还是一样的问题。

也可能是个案,是否与U盘格式有关系?


RE: 老大,不能升级(15、16版)(待确认) - nailoon - 08-05-2020

是不能升级 我的在宏碁笔记本上无法引导