Ventoy Forums
Icons or menu customization problem - Printable Version

+- Ventoy Forums (https://forums.ventoy.net)
+-- Forum: Ventoy Plugin (https://forums.ventoy.net/forumdisplay.php?fid=3)
+--- Forum: Ventoy Plugin Forum (https://forums.ventoy.net/forumdisplay.php?fid=4)
+--- Thread: Icons or menu customization problem (/showthread.php?tid=1876)

Pages: 1 2


Icons or menu customization problem - Eliott - 11-08-2021

Hello.
I have a problem with the customization of the menus.
I use ventoy since version 1.0.34.
Until version 1.0.39, when I upgraded, everything worked fine.
Since I wanted to upgrade to 1.0.40, the updates work but most of the icons I created to enhance the menus are not displayed anymore.
I don't change anything on my icons, just doing an update with the new release.

1.0.39
[attachment=460]

1.0.58
[attachment=461]

Any idea why this is happening?
Thanks for your help.


RE: Icons or menu customization problem - Steve2926 - 11-08-2021

Why does Rescue disk icon appear but not others?
Is the icon file in a different folder?
Does it have a different extension or size?
maybe you can show us ventoy.json and theme folder contents?


RE: Icons or menu customization problem - Eliott - 11-08-2021

Hello Steve2926.
Thanks for reply.
All my icons, whether in 1.0.39 or in 1.0.58 version are in the folder \ventoy\Themes\Solo2\icons.
They are all in .png format and their size is 72pppx72ppp.
it is not a question of weight because some of the icons that do not appear are lighter and others are heavier. The one that appears is 23kb, the one from easyUefi is 13kb and the one from RescueZilla is 29kb (Both doesn't appear).
I don't change anything when I upgrade my usb key to a higher version.
For the ventoy.cfg file, I didn't touch it, I don't even know where it is (I didn't know this file exists). I will look for it (maybe in a hidden partition that I didn't think to look for).
For customization, I only modified the ventoy.json and theme.txt files, and I never touched them when doing the ugrades.


RE: Icons or menu customization problem - Steve2926 - 11-08-2021

I meant ventoy.json file (not ventoy.cfg). sorry.


RE: Icons or menu customization problem - longpanda - 11-09-2021

(11-08-2021, 03:37 PM)Eliott Wrote: Hello.
I have a problem with the customization of the menus.
I use ventoy since version 1.0.34.
Until version 1.0.39, when I upgraded, everything worked fine.
Since I wanted to upgrade to 1.0.40, the updates work but most of the icons I created to enhance the menus are not displayed anymore.
I don't change anything on my icons, just doing an update with the new release.

1.0.39


1.0.58


Any idea why this is happening?
Thanks for your help.

Please comress your ventoy directory and upload it.
The upgrade operation is safe so you can do many times.
You can upgrade from 1.0.39 --> 1.0.58 --> 1.0.39--> 1.0.58 --> 1.0.39--> 1.0.58
to see whether it display OK in 1.0.39 and has problem in 1.0.58 for every test.



RE: Icons or menu customization problem - Eliott - 11-09-2021

(11-08-2021, 10:20 PM)Steve2926 Wrote: I meant ventoy.json file (not ventoy.cfg). sorry.
[Image: cool.png] No problem.

(11-09-2021, 12:53 AM)longpanda Wrote: Please comress your ventoy directory and upload it.
The upgrade operation is safe so you can do many times.
You can upgrade from 1.0.39 --> 1.0.58 --> 1.0.39--> 1.0.58 --> 1.0.39--> 1.0.58
to see whether it display OK in 1.0.39 and has problem in 1.0.58 for every test.
Hello longpanda.

I have already done several updates from 1.0.39 to a higher version and then back to 1.0.39 without losing anything.
Each time I went back to 1.0.39, the icons not displayed in the higher version are back.


RE: Icons or menu customization problem - Steve2926 - 11-09-2021

Are you testing on just one PC or many different PCs and Virtual Machines?
If not, can you try other systems?
Are you legacy booting or UEFI64 booting or UEFI32 booting or some other platform? Does problem exist in all of these?
How have you prepared the Ventoy USB drive? Secure Boot? exFAT for Ptn1? MBR or GPT?


RE: Icons or menu customization problem - Eliott - 11-09-2021

(11-09-2021, 05:06 PM)Steve2926 Wrote: Are you testing on just one PC or many different PCs and Virtual Machines?
If not, can you try other systems?
Are you legacy booting or UEFI64 booting or UEFI32 booting or some other platform? Does problem exist in all of these?
How have you prepared the Ventoy USB drive? Secure Boot? exFAT for Ptn1? MBR or GPT?
Hi Steve.

I tested in different conditions to try to eliminate as many causes as possible and on four different machines, all in 64bits:
I also tried using the QEMU emulator on one of the 4 machines.
The problem is present on all testing configuration.

All my machines are in "Legacy" bios (so in MBR), I don't use UEFI bios and SecureBoot is turned off on each PC.

My actual stick is formatted in NTFS (MBR).

I plan to test on another key directly installed in recent version (probably in 1.0.58) and formatted in ExtFat (it's a 64GB stick so too big for FAT32).

We'll see if the problem is still the same. I would be surprised if it makes a difference but I will try to eliminate an other possible cause.


RE: Icons or menu customization problem - longpanda - 11-10-2021

Please comress your ventoy directory and upload it. I need your configuration for test.


RE: Icons or menu customization problem - Steve2926 - 11-10-2021

Similar issue in grub2 here
https://github.com/a1ive/grub/issues/61
a1ive put it down to grub2 buggy.
Need to see your theme files...