Ventoy Forums

Full Version: Boot Linux from VHD ???
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
(10-08-2020, 09:27 AM)Egyptian Raptor Wrote: [ -> ]
(10-08-2020, 04:50 AM)longpanda Wrote: [ -> ]
(09-28-2020, 06:07 PM)Egyptian Raptor Wrote: [ -> ]
(09-28-2020, 10:06 AM)longpanda Wrote: [ -> ]What is the error? some photos?

Thanks for the prompt reply and sorry for my delay as I had to take the kids to their Tennis training,

I will put 5 pictures of the issue the describes the sequence of prompts starting from choosing the VHD to errors.
Keep in mind I did the vtoy command in the VM prior to using the VHD, also It is a fixed disk image with a fully installed and updated Kali Linux.

[Image: view?usp=sharing]
[Image: view?usp=sharing]
[Image: view?usp=sharing]
[Image: view?usp=sharing]
[Image: view?usp=sharing]

Sure hope this explains it. Thanks again.

p.s. Just in case if the images do not show

Which BIOS mode did you use? Legacy BIOS or UEFI?

If you used Legacy BIOS mode you can change to UEFI mode and retry.
But you need to reinstall Kali in UEFI mode also (with virtual machine).

Hi. I had already tried it with UEFI using another installation and still the same issue. The only thing that I see that could be a problem is that HyperV first creat a Dynamic VHDX upon creation then I manually convert it to a Fixed Size VHD, would this be a problem??

I have no idea about this. You can try with a vdi file (VirtualBox) with fixed size.
I have to state that the latest ventoy solved the Kali Boot issue and now can boot easily from Kali VHD file.

Thanks a lot for constant support.
Pages: 1 2