Ventoy Forums

Full Version: ISOs in Ventoy partition not visible
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I am a newcomer to Ventoy and like the idea of being able to select among multiple ISOs to boot. However, after preparing a 32GB USB stick with Ventoy 1.0.90 under Linux and putting multiple ISOs on the stick, Ventoy is not able to see the ISOs on either of the two computers I tried.

Ventoy boots fine but there are no ISOs visible, nor can I find them when I use F2 to move around on the stick. Mounting the stick on another computer I see the ISOs in the Ventoy partition as expected.

What could I be doing wrong? Is there a step I have missed to make them visible in the Ventoy menu?
How old is your computer?
Try a different computer.
I have tried it on two computers, both less than two years old.

I should have mentioned in my first post that I tried both MBR and GPT on the Ventoy stick and that the Ventoy partition is formatted exfat.
Load the contents of the ventoy.json file; the location path of the iso-files and the ventoy file.json on a flash drive.
You should send video clips or illustrations
That does not seem necessary, I think my verbal description is quite clear.

I have now tried it on yet another computer with the same outcome, ie Ventoy boots fine but on the first Ventoy screen it states (I am taking this from memory now) "No ISOs or image files are available (press Return to reboot)". If I then use F2 to get a tree view and then select the ventoy partition it is also empty. I have also tried to switch to Grub2 by pressing CTRL-R and compatibility mode by pressing CTRL-I with no difference.

Any suggestion what I should look for? Are there some other files that need to be created on the Ventoy stick in order to see the available ISO files that may have been missed or otherwise not created?

Is this a Grub2 menu on the first Ventoy screen and do I need to do anything special to make the ISOs visible?
You try to boot ventoy on a virtual machine like qemu tester or virtualbox or vmware and record a video or take a picture, because to better understand your problem
Ventoy boots fine from the stick and on the Ventoy boot screen with the Ventoy messages with version number, UEFI, key bindings etc., I see the Ventoy screen with an empty frame and a message that there are no ISO or IMG files..

There is nothing else. Not sure what you expect spending time on a video would show in addition to what I have already stated?

What information are you looking for?
Because your case is unusual, you need an image or video clip to illustrate, in short, you are in need of help, but where is it difficult to record a screen clip or take a screenshot?
When you boot into Ventoy menu (with "No ISOs or image files are available (press Return to reboot)")
press c to enter grub shell and run  the following two commands as in the attachment picture:
ls -l
ls ($vtoy_dev,1)/

Then take a photo about your result and upload here.
Pages: 1 2 3