Ventoy Forums

Full Version: Ventoy menu items not being displayed on live machine.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
(01-05-2023, 08:44 AM)Steve2926 Wrote: [ -> ]If QEMU displays OK then the problem must be with the physical PC, PC BIOS or USB drive.
So try different PCs,
try different USB drivea (different types and different sizes of USB drive)
try different filesystems for Partition 1 (exFAT, NTFS, FAT, etc.)
What PC are you using? What USB drive are you using?

That's what I thought at first. But then I never updated bios or changed anything on my system.
I did try different USB drives with different configurations. No luck.

I then started going through older versions of ventoy which worked fine with my PC.
It turns out that the last version that boots fine and properly displays ventoy theme is Ventoy Version 1.0.82.

So, something must have been changed by lognpanda in newer releases to cause this behavior.
Did you try in different PCs?
You test in Legacy BIOS mode or UEFI mode?
I tested in Legacy bios. I don't have uefi mode on this PC.
Ventoy 1.0.86 works properly on a laptop I have, both in uefi and legacy mode.

I have to correct myself.
The last version that works well on my PC in legacy mode is 1.0.82.
What about the latest 1.0.87 release?
(01-07-2023, 12:18 PM)longpanda Wrote: [ -> ]What about the latest 1.0.87 release?
Thank you for the new release.
Unfortunately the issue with menu elements not displaying is still there when booting in legacy mode on my machine.

In QUEMU using a legacy boot, I get the following errors with custom theme.
Tried the latest 1.0.87 release on a smaller usb stick (64GB) and it worked fine in legacy mode, with the exception of not loading the 
{ "VTOY_DEFAULT_IMAGE": "F4>Search and boot Windows" }. Maybe has to do with the error in my previous post.

Prior I was using 256GB usb sick with the workaround #2 from here.
And this workaround worked fine on all versions of Ventoy up until the last few versions. 
You should have stated earlier that your BIOS has access limit and you were using workaround #2.
Try this CI release:
Never thought to mention this, because nothing was changed regarding the procedure for workaround #2.
Also, I never mentioned this because, I never had the behavior you described on your Legacy BIOS Access Range Limitation page -
"2. Directly dropped into a grub shell when boot Ventoy" That never happened.

Great news  Smile 
The cli version fixed menus and hot key bar not being displayed. 

The issue with { "VTOY_DEFAULT_IMAGE": "F4>Search and Boot Windows" } not displaying proper boot entries remains.
Instead of displaying legacy boot options, ventoy displays uefi boot options in legacy boot.
This is what version shows during legacy boot.
You send the files in ventoy usb here (except iso, vhd, img files and your data), both partitions. We will see where the error comes from.
(01-09-2023, 04:42 PM)nguyen ha thai trong Wrote: [ -> ]You send the files in ventoy usb here (except iso, vhd, img files and your data), both partitions. We will see where the error comes from.

Ok thank you.

But before I do that, did you try booting in legacy mode with  { "VTOY_DEFAULT_IMAGE": "F4>Search and Boot Windows" } in ventoy.json?

PS: Replacing localboot.cfg with the one from version fixes the problem for me.
Pages: 1 2 3