Ventoy Forums

Full Version: [SOLVED] Unable to launch Live Ventoy w/MX-Linux on ASUS X570 MB w/AMD Ryzen 9 5900X
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi, unable to run MX-Linux with / without Persistence on an ASUS X570 Mobo.

I can see the menu but upon choosing the desired option it only shows a blank, dark screen forever.

I can Ctrl-Alt-Del to reboot, though.

Json file is:

    "persistence" : [
            "image": "/MX-19.1_x64.iso",
            "backend": "/MX-19.1_x64.dat"

Dat file created successfully using script:

sudo sh -s 24576 -l MX-Persist

and located at root along with iso file.

USB stick is GPT formatted.

Any thoughts appreciated.
Can it boot ok if you don't have ventoy.json?
(09-21-2021, 10:13 AM)longpanda Wrote: [ -> ]Can it boot ok if  you don't have ventoy.json?
No. I removed ventoy folder and its content (ventoy.json) to no avail, same behavior.

BTW, same behavior for the latest MX-19.4.1_kde_x64.iso, too.

See video below.

My guess is because of my CPU AMD Ryzen 9 5900x 12-core?...

Perhaps I should try MX-19.1_ahs_x64.iso and or MX-19.4.1_ahs_x64.iso?...

Will give it a try...
Hi All!

Just FYI: I updated the ACPI BIOS-UEFI from Revision 3602 (from early 2021 that came with the ASUS X570 MB to the newest 4021 from 8/10/2021 while the MX-19.4.1_ahs_x64.iso and MX-19.4.1_ahs_x64.dat in the stick and now it looks like it's working with and without Persistence.

The only problems are I get:

(1) "a required swap file size" setting I'm not sure about the syntax to enter it (For instance I tried 8 [for 8 GB], 80, 800 and  8000 [for 8000 KB] and it complained it was out of range or something like that), and...  

(2) a "Non-Fatal Error Could not enable required root ! persistence (c = continue, p = power off, r = reboot)"

... which, I guess, are for a new post.

And, later on, I also will test ventoy for the original MX-19.1_x64.iso and corresponding MX-19.1_x64.dat to make sure it works just fine for persistence as well.
Hi again!

After updating my ASUS X570 MB BIOS_UEFI to the latest revision 4021 from 8/10/2021 I was able to boot Ventoy with the following ISO MX-Linux releases, all working just fine with/without Persistence:

MX-19.1_x64 ---> Goes to Command Line Install (cli-installer) on both w/wo Persistence. 




Also the errors messages referred in a previous post days ago "a required swap file size" and the "Non-Fatal Error"  are gone since I've set the correct /, homefs  and swap file sizes properly.

When I ordered the building of my PC-DT system months ago, I asked the seller to update the BIOS-UEFI fw in the process, as I learned in advance it has to be done prior to installing Linux on it. 

When the system was ready to be delivered, I asked him if it was done, and he confirmed "Yes it was!"...

So I relied on his reply and didn't bother to double check it... Until I ran into trouble...

Lesson learned...

I think this is my final post and will stamp it as SOLVED momentarily...